Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1477558

Re: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups

Path csiph.com!1.us.feeder.erje.net!feeder.erje.net!2.eu.feeder.erje.net!newsfeed.datemas.de!enother.net!enother.net!news.mixmin.net!aioe.org!gothmog.csi.it!bofh.it!news.nic.it!robomod
From Bjorn Helgaas <helgaas@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
Date Tue, 06 Sep 2016 17:50:01 +0200
Message-ID <seqNj-3PR-7@gated-at.bofh.it> (permalink)
References <s9bYB-7Fo-15@gated-at.bofh.it>
MIME-Version 1.0
Content-Type text/plain; charset=us-ascii
Content-Disposition inline
User-Agent Mutt/1.5.21 (2010-09-15)
Sender robomod@news.nic.it
List-ID <linux-kernel.vger.kernel.org>
X-Mailing-List linux-kernel@vger.kernel.org
Approved robomod@news.nic.it
Lines 26
Organization linux.* mail to news gateway
X-Original-Cc Bjorn Helgaas <bhelgaas@google.com>, "linux-pci@vger.kernel.org" <linux-pci@vger.kernel.org>, "gregkh@linuxfoundation.org" <gregkh@linuxfoundation.org>, KY Srinivasan <kys@microsoft.com>, "linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>, "devel@linuxdriverproject.org" <devel@linuxdriverproject.org>, "olaf@aepfle.de" <olaf@aepfle.de>, "apw@canonical.com" <apw@canonical.com>, "jasowang@redhat.com" <jasowang@redhat.com>, "vkuznets@redhat.com" <vkuznets@redhat.com>, Haiyang Zhang <haiyangz@microsoft.com>, Hadden Hoppert <haddenh@microsoft.com>, Stephen Hemminger <sthemmin@microsoft.com>
X-Original-Date Tue, 6 Sep 2016 10:40:45 -0500
X-Original-Message-ID <20160906154045.GB1214@localhost>
X-Original-References <MWHPR03MB266985BDDEE4EB1A9C481B0DBFEB0@MWHPR03MB2669.namprd03.prod.outlook.com>
X-Original-Sender linux-kernel-owner@vger.kernel.org
Xref csiph.com linux.kernel:1477558

Show key headers only | View raw


On Tue, Aug 23, 2016 at 04:42:41AM +0000, Dexuan Cui wrote:
> 
> 1. use zero-length array to make the code more readable.
> 2. remove an unused struct member.
> 3. small error handling improvement to some error cases.
> 
> Dexuan Cui (5):
>   PCI: hv: use zero-length message in struct pci_packet
>   PCI: hv: use pci_function_description[0] in struct definitions
>   PCI: hv: remove the unused 'wrk' in struct hv_pcibus_device
>   PCI: hv: hv_compose_msi_msg: handle the 'ret' value
>   PCI: hv: hv_pci_generic_compl(): handle the error case
> 
>  drivers/pci/host/pci-hyperv.c | 56 ++++++++++++++++++++++---------------------
>  1 file changed, 29 insertions(+), 27 deletions(-)

I'm waiting for an ack from the Hyper-V maintainers:

  Hyper-V CORE AND DRIVERS
  M:      "K. Y. Srinivasan" <kys@microsoft.com>
  M:      Haiyang Zhang <haiyangz@microsoft.com>
  L:      devel@linuxdriverproject.org
  S:      Maintained
  ...
  F:      drivers/pci/host/pci-hyperv.c
  ...

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

Re: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups Bjorn Helgaas <helgaas@kernel.org> - 2016-09-06 17:50 +0200
  RE: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups KY Srinivasan <kys@microsoft.com> - 2016-09-06 19:30 +0200

csiph-web