Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1477558 > unrolled thread

Re: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups

Started byBjorn Helgaas <helgaas@kernel.org>
First post2016-09-06 17:50 +0200
Last post2016-09-06 19:30 +0200
Articles 2 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups Bjorn Helgaas <helgaas@kernel.org> - 2016-09-06 17:50 +0200
    RE: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups KY Srinivasan <kys@microsoft.com> - 2016-09-06 19:30 +0200

#1477558 — Re: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups

FromBjorn Helgaas <helgaas@kernel.org>
Date2016-09-06 17:50 +0200
SubjectRe: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
Message-ID<seqNj-3PR-7@gated-at.bofh.it>
On Tue, Aug 23, 2016 at 04:42:41AM +0000, Dexuan Cui wrote:
> 
> 1. use zero-length array to make the code more readable.
> 2. remove an unused struct member.
> 3. small error handling improvement to some error cases.
> 
> Dexuan Cui (5):
>   PCI: hv: use zero-length message in struct pci_packet
>   PCI: hv: use pci_function_description[0] in struct definitions
>   PCI: hv: remove the unused 'wrk' in struct hv_pcibus_device
>   PCI: hv: hv_compose_msi_msg: handle the 'ret' value
>   PCI: hv: hv_pci_generic_compl(): handle the error case
> 
>  drivers/pci/host/pci-hyperv.c | 56 ++++++++++++++++++++++---------------------
>  1 file changed, 29 insertions(+), 27 deletions(-)

I'm waiting for an ack from the Hyper-V maintainers:

  Hyper-V CORE AND DRIVERS
  M:      "K. Y. Srinivasan" <kys@microsoft.com>
  M:      Haiyang Zhang <haiyangz@microsoft.com>
  L:      devel@linuxdriverproject.org
  S:      Maintained
  ...
  F:      drivers/pci/host/pci-hyperv.c
  ...

[toc] | [next] | [standalone]


#1477687

FromKY Srinivasan <kys@microsoft.com>
Date2016-09-06 19:30 +0200
Message-ID<sesm6-4Wc-21@gated-at.bofh.it>
In reply to#1477558

> -----Original Message-----
> From: Bjorn Helgaas [mailto:helgaas@kernel.org]
> Sent: Tuesday, September 6, 2016 9:11 PM
> To: Dexuan Cui <decui@microsoft.com>
> Cc: Bjorn Helgaas <bhelgaas@google.com>; linux-pci@vger.kernel.org;
> gregkh@linuxfoundation.org; KY Srinivasan <kys@microsoft.com>; linux-
> kernel@vger.kernel.org; devel@linuxdriverproject.org; olaf@aepfle.de;
> apw@canonical.com; jasowang@redhat.com; vkuznets@redhat.com; Haiyang
> Zhang <haiyangz@microsoft.com>; Hadden Hoppert
> <haddenh@microsoft.com>; Stephen Hemminger <sthemmin@microsoft.com>
> Subject: Re: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
> 
> On Tue, Aug 23, 2016 at 04:42:41AM +0000, Dexuan Cui wrote:
> >
> > 1. use zero-length array to make the code more readable.
> > 2. remove an unused struct member.
> > 3. small error handling improvement to some error cases.
> >
> > Dexuan Cui (5):
> >   PCI: hv: use zero-length message in struct pci_packet
> >   PCI: hv: use pci_function_description[0] in struct definitions
> >   PCI: hv: remove the unused 'wrk' in struct hv_pcibus_device
> >   PCI: hv: hv_compose_msi_msg: handle the 'ret' value
> >   PCI: hv: hv_pci_generic_compl(): handle the error case
> >
> >  drivers/pci/host/pci-hyperv.c | 56 ++++++++++++++++++++++--------------------
> -
> >  1 file changed, 29 insertions(+), 27 deletions(-)
> 
> I'm waiting for an ack from the Hyper-V maintainers:

I have Acked these patches.

K. Y
> 
>   Hyper-V CORE AND DRIVERS
>   M:      "K. Y. Srinivasan" <kys@microsoft.com>
>   M:      Haiyang Zhang <haiyangz@microsoft.com>
>   L:      devel@linuxdriverproject.org
>   S:      Maintained
>   ...
>   F:      drivers/pci/host/pci-hyperv.c
>   ...

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web