Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1473430

Re: [PATCH 0/9] ARM: dts: exynos: Use macros for GPIO to make it more readable

From Javier Martinez Canillas <javier@osg.samsung.com>
Newsgroups linux.kernel
Subject Re: [PATCH 0/9] ARM: dts: exynos: Use macros for GPIO to make it more readable
Date 2016-08-31 14:50 +0200
Message-ID <scd7P-2sm-17@gated-at.bofh.it> (permalink)
References <sccEN-2iO-11@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Hello Krzysztof,

On 08/31/2016 02:13 PM, Krzysztof Kozlowski wrote:
> Hi,
> 
> Example:
> -		samsung,pin-function = <0x2>;
> -		samsung,pin-pud = <0>;
> -		samsung,pin-drv = <0>;
> +		samsung,pin-function = <PIN_FUNC_SPC_2>;
> +		samsung,pin-pud = <PIN_PULL_NONE>;
> +		samsung,pin-drv = <PIN_DRV_LV1>;
>  
> This should be just more readable. Especially for drive strenghts which
> are unobvious and different between some SoCs.
>

I agree that's better to have macros for these instead of using magic numbers.

For all the series:

Reviewed-by: Javier Martinez Canillas <javier@osg.samsung.com>

> Tested with dtx_diff:
> for i in dts-old/exynos*dtb; do scripts/dtc/dtx_diff $i dts-new/$(basename $i);  done
>

I've also tested the patches on an Exynos5800 Peach Pi board, and as expected
everything is working correctly since the compiled DTB is exactly the same.

So for patches 1/9 and 9/9:

Tested-by: Javier Martinez Canillas <javier@osg.samsung.com>

Best regards,
-- 
Javier Martinez Canillas
Open Source Group
Samsung Research America

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH 0/9] ARM: dts: exynos: Use macros for GPIO to make it more  readable Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2016-08-31 14:20 +0200
  [PATCH 6/9] ARM: dts: exynos: Use macros for GPIO configuration on  exynos5250 Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2016-08-31 14:20 +0200
  [PATCH 2/9] ARM: dts: exynos: Use macros for GPIO configuration on  exynos3250 Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2016-08-31 14:20 +0200
  [PATCH 3/9] ARM: dts: exynos: Use macros for GPIO configuration on  exynos4210 Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2016-08-31 14:20 +0200
  [PATCH 5/9] ARM: dts: exynos: Use macros for GPIO configuration on  exynos4x12 Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2016-08-31 14:20 +0200
  [PATCH 4/9] ARM: dts: exynos: Use macros for GPIO configuration on  exynos4415 Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2016-08-31 14:20 +0200
  [PATCH 7/9] ARM: dts: exynos: Use macros for GPIO configuration on  exynos5260 Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2016-08-31 14:20 +0200
  [PATCH 1/9] ARM: dts: exynos: Add macros for GPIO configuration Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2016-08-31 14:20 +0200
    Re: [PATCH 1/9] ARM: dts: exynos: Add macros for GPIO configuration Arnd Bergmann <arnd@arndb.de> - 2016-08-31 14:50 +0200
      Re: [PATCH 1/9] ARM: dts: exynos: Add macros for GPIO configuration Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2016-08-31 15:00 +0200
        Re: [PATCH 1/9] ARM: dts: exynos: Add macros for GPIO configuration Arnd Bergmann <arnd@arndb.de> - 2016-08-31 15:10 +0200
          Re: [PATCH 1/9] ARM: dts: exynos: Add macros for GPIO configuration Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2016-08-31 15:10 +0200
            Re: [PATCH 1/9] ARM: dts: exynos: Add macros for GPIO configuration Arnd Bergmann <arnd@arndb.de> - 2016-08-31 15:40 +0200
  Re: [PATCH 0/9] ARM: dts: exynos: Use macros for GPIO to make it more  readable Javier Martinez Canillas <javier@osg.samsung.com> - 2016-08-31 14:50 +0200

csiph-web