Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1553940

[PATCH 0/8] MMC-core: Fine-tuning for some function implementations

From SF Markus Elfring <elfring@users.sourceforge.net>
Newsgroups linux.kernel
Subject [PATCH 0/8] MMC-core: Fine-tuning for some function implementations
Date 2017-01-08 22:50 +0100
Message-ID <sXtvH-3AV-7@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


From: Markus Elfring <elfring@users.sourceforge.net>
Date: Sun, 8 Jan 2017 22:30:03 +0100

Some update suggestions were taken into account
from static source code analysis.

Markus Elfring (8):
  Use kmalloc_array() in mmc_test_area_init()
  Fix a typo in a comment line
  Use seq_puts() in mtf_testlist_show()
  mmc_test: Add some spaces for better code readability
  mmc_test: Combine substrings for 5 messages
  mmc_test: Improve a size determination in five functions
  Use kcalloc() in mmc_test_alloc_mem()
  Use kmalloc_array() in mmc_alloc_sg()

 drivers/mmc/core/mmc_test.c | 77 +++++++++++++++++++++------------------------
 drivers/mmc/core/queue.c    |  2 +-
 2 files changed, 36 insertions(+), 43 deletions(-)

-- 
2.11.0

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[PATCH 0/8] MMC-core: Fine-tuning for some function implementations SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-08 22:50 +0100
  [PATCH 5/8] mmc/core/mmc_test: Combine substrings for 5 messages SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-08 22:50 +0100
    Re: [PATCH 5/8] mmc/core/mmc_test: Combine substrings for 5 messages Linus Walleij <linus.walleij@linaro.org> - 2017-01-09 19:40 +0100
    Re: [PATCH 5/8] mmc/core/mmc_test: Combine substrings for 5 messages Shawn Lin <shawn.lin@rock-chips.com> - 2017-01-10 09:40 +0100
  [PATCH 4/8] mmc/core/mmc_test: Add some spaces for better code  readability SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-08 22:50 +0100
    Re: [PATCH 4/8] mmc/core/mmc_test: Add some spaces for better code readability Linus Walleij <linus.walleij@linaro.org> - 2017-01-09 19:40 +0100
    Re: [PATCH 4/8] mmc/core/mmc_test: Add some spaces for better code  readability Shawn Lin <shawn.lin@rock-chips.com> - 2017-01-10 09:40 +0100
  [PATCH 1/8] mmc-core: Use kmalloc_array() in mmc_test_area_init() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-08 22:50 +0100
    Re: [PATCH 1/8] mmc-core: Use kmalloc_array() in mmc_test_area_init() Linus Walleij <linus.walleij@linaro.org> - 2017-01-09 19:40 +0100
      Re: [PATCH 1/8] mmc-core: Use kmalloc_array() in mmc_test_area_init() Chunyan Zhang <zhang.chunyan@linaro.org> - 2017-01-10 08:40 +0100
    Re: [PATCH 1/8] mmc-core: Use kmalloc_array() in mmc_test_area_init() Shawn Lin <shawn.lin@rock-chips.com> - 2017-01-10 09:50 +0100
    Re: [PATCH 1/8] mmc-core: Use kmalloc_array() in mmc_test_area_init() Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-01-11 03:00 +0100
  [PATCH 7/8] mmc-core: Use kcalloc() in mmc_test_alloc_mem() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-08 23:00 +0100
    Re: [PATCH 7/8] mmc-core: Use kcalloc() in mmc_test_alloc_mem() Linus Walleij <linus.walleij@linaro.org> - 2017-01-09 19:40 +0100
    Re: [PATCH 7/8] mmc-core: Use kcalloc() in mmc_test_alloc_mem() Shawn Lin <shawn.lin@rock-chips.com> - 2017-01-10 09:30 +0100
  [PATCH 6/8] mmc/core/mmc_test: Improve a size determination in five  functions SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-08 23:00 +0100
    Re: [PATCH 6/8] mmc/core/mmc_test: Improve a size determination in  five functions Linus Walleij <linus.walleij@linaro.org> - 2017-01-09 19:40 +0100
    Re: [PATCH 6/8] mmc/core/mmc_test: Improve a size determination in  five functions Shawn Lin <shawn.lin@rock-chips.com> - 2017-01-10 09:40 +0100
  [PATCH 8/8] mmc-core: Use kmalloc_array() in mmc_alloc_sg() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-08 23:20 +0100
    Re: [PATCH 8/8] mmc-core: Use kmalloc_array() in mmc_alloc_sg() Linus Walleij <linus.walleij@linaro.org> - 2017-01-09 19:40 +0100
    Re: [PATCH 8/8] mmc-core: Use kmalloc_array() in mmc_alloc_sg() Shawn Lin <shawn.lin@rock-chips.com> - 2017-01-10 09:30 +0100
  Re: [PATCH 0/8] MMC-core: Fine-tuning for some function implementations Ulf Hansson <ulf.hansson@linaro.org> - 2017-01-12 13:10 +0100

csiph-web