Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1555011
| From | Chunyan Zhang <zhang.chunyan@linaro.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 1/8] mmc-core: Use kmalloc_array() in mmc_test_area_init() |
| Date | 2017-01-10 08:40 +0100 |
| Message-ID | <sXZce-6TT-19@gated-at.bofh.it> (permalink) |
| References | <sXtvH-3AV-7@gated-at.bofh.it> <sXtvI-3AV-25@gated-at.bofh.it> <sXN1o-7G5-21@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 10 January 2017 at 02:31, Linus Walleij <linus.walleij@linaro.org> wrote: > On Sun, Jan 8, 2017 at 10:42 PM, SF Markus Elfring > <elfring@users.sourceforge.net> wrote: > >> From: Markus Elfring <elfring@users.sourceforge.net> >> Date: Sun, 8 Jan 2017 18:44:26 +0100 >> >> * A multiplication for the size determination of a memory allocation >> indicated that an array data structure should be processed. >> Thus use the corresponding function "kmalloc_array". >> >> This issue was detected by using the Coccinelle software. >> >> * Replace the specification of a data structure by a pointer dereference >> to make the corresponding size determination a bit safer according to >> the Linux coding style convention. >> >> Signed-off-by: Markus Elfring <elfring@users.sourceforge.net> > > Chunyan has been running this test code so she might have additional > insights to provide. I am not aware about anyone else really running the > tests, are there people who do it? I talked about mmc_test on #armlinux channel with a person whose nickname was s84 other day. It seemed that s84 was also trying to use mmc_test module. Regards, Chunyan > > Reviewed-by: Linus Walleij <linus.walleij@linaro.org> > > Yours, > Linus Walleij
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 0/8] MMC-core: Fine-tuning for some function implementations SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-08 22:50 +0100
[PATCH 5/8] mmc/core/mmc_test: Combine substrings for 5 messages SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-08 22:50 +0100
Re: [PATCH 5/8] mmc/core/mmc_test: Combine substrings for 5 messages Linus Walleij <linus.walleij@linaro.org> - 2017-01-09 19:40 +0100
Re: [PATCH 5/8] mmc/core/mmc_test: Combine substrings for 5 messages Shawn Lin <shawn.lin@rock-chips.com> - 2017-01-10 09:40 +0100
[PATCH 4/8] mmc/core/mmc_test: Add some spaces for better code readability SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-08 22:50 +0100
Re: [PATCH 4/8] mmc/core/mmc_test: Add some spaces for better code readability Linus Walleij <linus.walleij@linaro.org> - 2017-01-09 19:40 +0100
Re: [PATCH 4/8] mmc/core/mmc_test: Add some spaces for better code readability Shawn Lin <shawn.lin@rock-chips.com> - 2017-01-10 09:40 +0100
[PATCH 1/8] mmc-core: Use kmalloc_array() in mmc_test_area_init() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-08 22:50 +0100
Re: [PATCH 1/8] mmc-core: Use kmalloc_array() in mmc_test_area_init() Linus Walleij <linus.walleij@linaro.org> - 2017-01-09 19:40 +0100
Re: [PATCH 1/8] mmc-core: Use kmalloc_array() in mmc_test_area_init() Chunyan Zhang <zhang.chunyan@linaro.org> - 2017-01-10 08:40 +0100
Re: [PATCH 1/8] mmc-core: Use kmalloc_array() in mmc_test_area_init() Shawn Lin <shawn.lin@rock-chips.com> - 2017-01-10 09:50 +0100
Re: [PATCH 1/8] mmc-core: Use kmalloc_array() in mmc_test_area_init() Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-01-11 03:00 +0100
[PATCH 7/8] mmc-core: Use kcalloc() in mmc_test_alloc_mem() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-08 23:00 +0100
Re: [PATCH 7/8] mmc-core: Use kcalloc() in mmc_test_alloc_mem() Linus Walleij <linus.walleij@linaro.org> - 2017-01-09 19:40 +0100
Re: [PATCH 7/8] mmc-core: Use kcalloc() in mmc_test_alloc_mem() Shawn Lin <shawn.lin@rock-chips.com> - 2017-01-10 09:30 +0100
[PATCH 6/8] mmc/core/mmc_test: Improve a size determination in five functions SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-08 23:00 +0100
Re: [PATCH 6/8] mmc/core/mmc_test: Improve a size determination in five functions Linus Walleij <linus.walleij@linaro.org> - 2017-01-09 19:40 +0100
Re: [PATCH 6/8] mmc/core/mmc_test: Improve a size determination in five functions Shawn Lin <shawn.lin@rock-chips.com> - 2017-01-10 09:40 +0100
[PATCH 8/8] mmc-core: Use kmalloc_array() in mmc_alloc_sg() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-08 23:20 +0100
Re: [PATCH 8/8] mmc-core: Use kmalloc_array() in mmc_alloc_sg() Linus Walleij <linus.walleij@linaro.org> - 2017-01-09 19:40 +0100
Re: [PATCH 8/8] mmc-core: Use kmalloc_array() in mmc_alloc_sg() Shawn Lin <shawn.lin@rock-chips.com> - 2017-01-10 09:30 +0100
Re: [PATCH 0/8] MMC-core: Fine-tuning for some function implementations Ulf Hansson <ulf.hansson@linaro.org> - 2017-01-12 13:10 +0100
csiph-web