Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1539167
| From | Milo Kim <woogyom.kim@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH v2 7/8] power: supply: tps65217: Use generic name for get_property() |
| Date | 2016-12-09 09:00 +0100 |
| Message-ID | <sMog1-xv-3@gated-at.bofh.it> (permalink) |
| References | <sMo6l-ug-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Rename it as tps65217_charger_get_property().
Signed-off-by: Milo Kim <woogyom.kim@gmail.com>
---
drivers/power/supply/tps65217_charger.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/power/supply/tps65217_charger.c b/drivers/power/supply/tps65217_charger.c
index 79afeca..63c5556 100644
--- a/drivers/power/supply/tps65217_charger.c
+++ b/drivers/power/supply/tps65217_charger.c
@@ -115,9 +115,9 @@ static int tps65217_enable_charging(struct tps65217_charger *charger)
return 0;
}
-static int tps65217_ac_get_property(struct power_supply *psy,
- enum power_supply_property psp,
- union power_supply_propval *val)
+static int tps65217_charger_get_property(struct power_supply *psy,
+ enum power_supply_property psp,
+ union power_supply_propval *val)
{
struct tps65217_charger *charger = power_supply_get_drvdata(psy);
@@ -190,7 +190,7 @@ static int tps65217_charger_poll_task(void *data)
static const struct power_supply_desc tps65217_charger_desc = {
.name = "tps65217-ac",
.type = POWER_SUPPLY_TYPE_MAINS,
- .get_property = tps65217_ac_get_property,
+ .get_property = tps65217_charger_get_property,
.properties = tps65217_charger_props,
.num_properties = ARRAY_SIZE(tps65217_charger_props),
};
--
2.9.3
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v2 0/8] power: supply: tps65217: Support USB charger feature Milo Kim <woogyom.kim@gmail.com> - 2016-12-09 08:50 +0100 [PATCH v2 7/8] power: supply: tps65217: Use generic name for get_property() Milo Kim <woogyom.kim@gmail.com> - 2016-12-09 09:00 +0100 [PATCH v2 5/8] power: supply: tps65217: Use generic name for power supply structure Milo Kim <woogyom.kim@gmail.com> - 2016-12-09 09:00 +0100 [PATCH v2 2/8] power: supply: tps65217: Use 'poll_task' on unloading the module Milo Kim <woogyom.kim@gmail.com> - 2016-12-09 09:00 +0100
csiph-web