Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1539163

[PATCH v2 0/8] power: supply: tps65217: Support USB charger feature

From Milo Kim <woogyom.kim@gmail.com>
Newsgroups linux.kernel
Subject [PATCH v2 0/8] power: supply: tps65217: Support USB charger feature
Date 2016-12-09 08:50 +0100
Message-ID <sMo6l-ug-5@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


TPS65217 device supports two charger inputs - AC and USB.
Currently, only AC charger is supported. This patch-set adds USB charger 
feature. Tested on Beaglebone black.

Patch 1: Main patch
Patch 2, 3: Clean up for charger driver data
Patch 4 ~ 8: Naming changes for generic power supply class structure

v2:
  Regenerate the patchset for better code review

Milo Kim (8):
  power: supply: tps65217: Support USB charger interrupt
  power: supply: tps65217: Use 'poll_task' on unloading the module
  power: supply: tps65217: Remove IRQ data from driver data
  power: supply: tps65217: Use generic name for charger online
  power: supply: tps65217: Use generic name for power supply structure
  power: supply: tps65217: Use generic name for power supply property
  power: supply: tps65217: Use generic name for get_property()
  power: supply: tps65217: Use generic charger name

 drivers/power/supply/tps65217_charger.c | 99 ++++++++++++++++++---------------
 1 file changed, 53 insertions(+), 46 deletions(-)

-- 
2.9.3

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[PATCH v2 0/8] power: supply: tps65217: Support USB charger feature Milo Kim <woogyom.kim@gmail.com> - 2016-12-09 08:50 +0100
  [PATCH v2 7/8] power: supply: tps65217: Use generic name for get_property() Milo Kim <woogyom.kim@gmail.com> - 2016-12-09 09:00 +0100
  [PATCH v2 5/8] power: supply: tps65217: Use generic name for power supply structure Milo Kim <woogyom.kim@gmail.com> - 2016-12-09 09:00 +0100
  [PATCH v2 2/8] power: supply: tps65217: Use 'poll_task' on unloading the module Milo Kim <woogyom.kim@gmail.com> - 2016-12-09 09:00 +0100

csiph-web