Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1539169

[PATCH v2 5/8] power: supply: tps65217: Use generic name for power supply structure

From Milo Kim <woogyom.kim@gmail.com>
Newsgroups linux.kernel
Subject [PATCH v2 5/8] power: supply: tps65217: Use generic name for power supply structure
Date 2016-12-09 09:00 +0100
Message-ID <sMog1-xv-13@gated-at.bofh.it> (permalink)
References <sMo6l-ug-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Replace 'ac' of tps65217_charger structure with 'psy'.

Signed-off-by: Milo Kim <woogyom.kim@gmail.com>
---
 drivers/power/supply/tps65217_charger.c | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

diff --git a/drivers/power/supply/tps65217_charger.c b/drivers/power/supply/tps65217_charger.c
index 424a6d3..5daf361 100644
--- a/drivers/power/supply/tps65217_charger.c
+++ b/drivers/power/supply/tps65217_charger.c
@@ -42,7 +42,7 @@
 struct tps65217_charger {
 	struct tps65217 *tps;
 	struct device *dev;
-	struct power_supply *ac;
+	struct power_supply *psy;
 
 	int	online;
 	int	prev_online;
@@ -157,7 +157,7 @@ static irqreturn_t tps65217_charger_irq(int irq, void *dev)
 	}
 
 	if (charger->prev_online != charger->online)
-		power_supply_changed(charger->ac);
+		power_supply_changed(charger->psy);
 
 	ret = tps65217_reg_read(charger->tps, TPS65217_REG_CHGCONFIG0, &val);
 	if (ret < 0) {
@@ -218,12 +218,12 @@ static int tps65217_charger_probe(struct platform_device *pdev)
 	cfg.of_node = pdev->dev.of_node;
 	cfg.drv_data = charger;
 
-	charger->ac = devm_power_supply_register(&pdev->dev,
-						 &tps65217_charger_desc,
-						 &cfg);
-	if (IS_ERR(charger->ac)) {
+	charger->psy = devm_power_supply_register(&pdev->dev,
+						  &tps65217_charger_desc,
+						  &cfg);
+	if (IS_ERR(charger->psy)) {
 		dev_err(&pdev->dev, "failed: power supply register\n");
-		return PTR_ERR(charger->ac);
+		return PTR_ERR(charger->psy);
 	}
 
 	irq[0] = platform_get_irq_byname(pdev, "USB");
-- 
2.9.3

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v2 0/8] power: supply: tps65217: Support USB charger feature Milo Kim <woogyom.kim@gmail.com> - 2016-12-09 08:50 +0100
  [PATCH v2 7/8] power: supply: tps65217: Use generic name for get_property() Milo Kim <woogyom.kim@gmail.com> - 2016-12-09 09:00 +0100
  [PATCH v2 5/8] power: supply: tps65217: Use generic name for power supply structure Milo Kim <woogyom.kim@gmail.com> - 2016-12-09 09:00 +0100
  [PATCH v2 2/8] power: supply: tps65217: Use 'poll_task' on unloading the module Milo Kim <woogyom.kim@gmail.com> - 2016-12-09 09:00 +0100

csiph-web