Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1522690

[PATCH 4/5] power: supply: tps65217: Use generic name for charger online

From Milo Kim <woogyom.kim@gmail.com>
Newsgroups linux.kernel
Subject [PATCH 4/5] power: supply: tps65217: Use generic name for charger online
Date 2016-11-15 14:20 +0100
Message-ID <sDLOz-5pg-49@gated-at.bofh.it> (permalink)
References <sDLOy-5pg-19@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


This driver supports AC and USB chargers. Generic name is preferred.

  ac_online -> online
  prev_ac_online -> prev_online

Cc: Enric Balletbo i Serra <enric.balletbo@collabora.com>
Signed-off-by: Milo Kim <woogyom.kim@gmail.com>
---
 drivers/power/supply/tps65217_charger.c | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)

diff --git a/drivers/power/supply/tps65217_charger.c b/drivers/power/supply/tps65217_charger.c
index 2894132..8b7ce61 100644
--- a/drivers/power/supply/tps65217_charger.c
+++ b/drivers/power/supply/tps65217_charger.c
@@ -44,8 +44,8 @@ struct tps65217_charger {
 	struct device *dev;
 	struct power_supply *ac;
 
-	int	ac_online;
-	int	prev_ac_online;
+	int	online;
+	int	prev_online;
 
 	struct task_struct	*poll_task;
 };
@@ -95,7 +95,7 @@ static int tps65217_enable_charging(struct tps65217_charger *charger)
 	int ret;
 
 	/* charger already enabled */
-	if (charger->ac_online)
+	if (charger->online)
 		return 0;
 
 	dev_dbg(charger->dev, "%s: enable charging\n", __func__);
@@ -110,7 +110,7 @@ static int tps65217_enable_charging(struct tps65217_charger *charger)
 		return ret;
 	}
 
-	charger->ac_online = 1;
+	charger->online = 1;
 
 	return 0;
 }
@@ -122,7 +122,7 @@ static int tps65217_ac_get_property(struct power_supply *psy,
 	struct tps65217_charger *charger = power_supply_get_drvdata(psy);
 
 	if (psp == POWER_SUPPLY_PROP_ONLINE) {
-		val->intval = charger->ac_online;
+		val->intval = charger->online;
 		return 0;
 	}
 	return -EINVAL;
@@ -133,7 +133,7 @@ static irqreturn_t tps65217_charger_irq(int irq, void *dev)
 	int ret, val;
 	struct tps65217_charger *charger = dev;
 
-	charger->prev_ac_online = charger->ac_online;
+	charger->prev_online = charger->online;
 
 	ret = tps65217_reg_read(charger->tps, TPS65217_REG_STATUS, &val);
 	if (ret < 0) {
@@ -153,10 +153,10 @@ static irqreturn_t tps65217_charger_irq(int irq, void *dev)
 			return IRQ_HANDLED;
 		}
 	} else {
-		charger->ac_online = 0;
+		charger->online = 0;
 	}
 
-	if (charger->prev_ac_online != charger->ac_online)
+	if (charger->prev_online != charger->online)
 		power_supply_changed(charger->ac);
 
 	ret = tps65217_reg_read(charger->tps, TPS65217_REG_CHGCONFIG0, &val);
-- 
2.9.3

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 0/5] power: supply: tps65217: Support USB charger feature Milo Kim <woogyom.kim@gmail.com> - 2016-11-15 14:20 +0100
  [PATCH 5/5] power: supply: tps65217: Use generic name for power supply structures Milo Kim <woogyom.kim@gmail.com> - 2016-11-15 14:20 +0100
  [PATCH 2/5] power: supply: tps65217: Remove IRQ data from driver data Milo Kim <woogyom.kim@gmail.com> - 2016-11-15 14:20 +0100
    Re: [PATCH 2/5] power: supply: tps65217: Remove IRQ data from driver  data Sebastian Reichel <sre@kernel.org> - 2016-11-22 18:00 +0100
      Re: [PATCH 2/5] power: supply: tps65217: Remove IRQ data from driver  data Sebastian Reichel <sre@kernel.org> - 2016-11-22 18:00 +0100
        Re: [PATCH 2/5] power: supply: tps65217: Remove IRQ data from driver  data Milo Kim <woogyom.kim@gmail.com> - 2016-11-23 12:50 +0100
  [PATCH 4/5] power: supply: tps65217: Use generic name for charger online Milo Kim <woogyom.kim@gmail.com> - 2016-11-15 14:20 +0100
  [PATCH 1/5] power: supply: tps65217: Move IRQ related operation into single function Milo Kim <woogyom.kim@gmail.com> - 2016-11-15 14:30 +0100
    Re: [PATCH 1/5] power: supply: tps65217: Move IRQ related operation  into single function Sebastian Reichel <sre@kernel.org> - 2016-11-22 18:00 +0100
      Re: [PATCH 1/5] power: supply: tps65217: Move IRQ related operation  into single function Sebastian Reichel <sre@kernel.org> - 2016-11-22 18:00 +0100
  [PATCH 3/5] power: supply: tps65217: Support USB charger interrupt Milo Kim <woogyom.kim@gmail.com> - 2016-11-15 14:30 +0100

csiph-web