Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1522679

[PATCH 0/5] power: supply: tps65217: Support USB charger feature

From Milo Kim <woogyom.kim@gmail.com>
Newsgroups linux.kernel
Subject [PATCH 0/5] power: supply: tps65217: Support USB charger feature
Date 2016-11-15 14:20 +0100
Message-ID <sDLOy-5pg-19@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


TPS65217 device supports two charger inputs - AC and USB.
Currently, only AC charger is supported. This patch-set adds USB charger 
feature. Tested on Beaglebone black.

Milo Kim (5):
  power: supply: tps65217: Move IRQ related operation into single
    function
  power: supply: tps65217: Remove IRQ data from driver data
  power: supply: tps65217: Support USB charger interrupt
  power: supply: tps65217: Use generic name for charger online
  power: supply: tps65217: Use generic name for power supply structures

 drivers/power/supply/tps65217_charger.c | 133 ++++++++++++++++++--------------
 1 file changed, 73 insertions(+), 60 deletions(-)

-- 
2.9.3

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[PATCH 0/5] power: supply: tps65217: Support USB charger feature Milo Kim <woogyom.kim@gmail.com> - 2016-11-15 14:20 +0100
  [PATCH 5/5] power: supply: tps65217: Use generic name for power supply structures Milo Kim <woogyom.kim@gmail.com> - 2016-11-15 14:20 +0100
  [PATCH 2/5] power: supply: tps65217: Remove IRQ data from driver data Milo Kim <woogyom.kim@gmail.com> - 2016-11-15 14:20 +0100
    Re: [PATCH 2/5] power: supply: tps65217: Remove IRQ data from driver  data Sebastian Reichel <sre@kernel.org> - 2016-11-22 18:00 +0100
      Re: [PATCH 2/5] power: supply: tps65217: Remove IRQ data from driver  data Sebastian Reichel <sre@kernel.org> - 2016-11-22 18:00 +0100
        Re: [PATCH 2/5] power: supply: tps65217: Remove IRQ data from driver  data Milo Kim <woogyom.kim@gmail.com> - 2016-11-23 12:50 +0100
  [PATCH 4/5] power: supply: tps65217: Use generic name for charger online Milo Kim <woogyom.kim@gmail.com> - 2016-11-15 14:20 +0100
  [PATCH 1/5] power: supply: tps65217: Move IRQ related operation into single function Milo Kim <woogyom.kim@gmail.com> - 2016-11-15 14:30 +0100
    Re: [PATCH 1/5] power: supply: tps65217: Move IRQ related operation  into single function Sebastian Reichel <sre@kernel.org> - 2016-11-22 18:00 +0100
      Re: [PATCH 1/5] power: supply: tps65217: Move IRQ related operation  into single function Sebastian Reichel <sre@kernel.org> - 2016-11-22 18:00 +0100
  [PATCH 3/5] power: supply: tps65217: Support USB charger interrupt Milo Kim <woogyom.kim@gmail.com> - 2016-11-15 14:30 +0100

csiph-web