Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1398326

Re: [PATCH v5 02/13] x86/xsaves: Rename xstate_size to kernel_xstate_size to explicitly distinguish xstate size in kernel from user space

From Dave Hansen <dave.hansen@linux.intel.com>
Newsgroups linux.kernel
Subject Re: [PATCH v5 02/13] x86/xsaves: Rename xstate_size to kernel_xstate_size to explicitly distinguish xstate size in kernel from user space
Date 2016-05-10 19:10 +0200
Message-ID <rxjku-6P9-11@gated-at.bofh.it> (permalink)
References <rx0rx-4yi-11@gated-at.bofh.it> <rx0rx-4yi-21@gated-at.bofh.it> <rxjku-6P9-13@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 05/10/2016 10:01 AM, Borislav Petkov wrote:
>> >  	pr_info("x86/fpu: Enabled xstate features 0x%llx, context size is %d bytes, using '%s' format.\n",
>> >  		xfeatures_mask,
>> > -		xstate_size,
>> > +		kernel_xstate_size,
>> >  		cpu_has_xsaves ? "compacted" : "standard");
> I think we should dump user_xstate_size in the compacted case since it
> is != kernel_xstate_size.

Why?  "kernel_xstate_size" is important to the kernel because it impacts
task_struct size.

But the kernel never actually stores "user_xstate_size" anywhere or
really ever even cares about it except when copying in/out of userspace.
 "user_xstate_size" is also entirely enumerable in userspace with a
single cpuid instruction.

It's nice to dump out interesting data in dmesg, but I'm curious why you
think it's interesting.

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v5 02/13] x86/xsaves: Rename xstate_size to kernel_xstate_size to explicitly distinguish xstate size in kernel from user space Yu-cheng Yu <yu-cheng.yu@intel.com> - 2016-05-09 23:00 +0200
  Re: [PATCH v5 02/13] x86/xsaves: Rename xstate_size to  kernel_xstate_size to explicitly distinguish xstate size in kernel from user  space Dave Hansen <dave.hansen@linux.intel.com> - 2016-05-10 19:10 +0200
    Re: [PATCH v5 02/13] x86/xsaves: Rename xstate_size to  kernel_xstate_size to explicitly distinguish xstate size in kernel from user  space Borislav Petkov <bp@suse.de> - 2016-05-10 19:30 +0200
      Re: [PATCH v5 02/13] x86/xsaves: Rename xstate_size to  kernel_xstate_size to explicitly distinguish xstate size in kernel from user  space Dave Hansen <dave.hansen@linux.intel.com> - 2016-05-10 19:40 +0200
  Re: [PATCH v5 02/13] x86/xsaves: Rename xstate_size to  kernel_xstate_size to explicitly distinguish xstate size in kernel from user  space Borislav Petkov <bp@suse.de> - 2016-05-10 19:10 +0200

csiph-web