Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1398351
| From | Dave Hansen <dave.hansen@linux.intel.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v5 02/13] x86/xsaves: Rename xstate_size to kernel_xstate_size to explicitly distinguish xstate size in kernel from user space |
| Date | 2016-05-10 19:40 +0200 |
| Message-ID | <rxjNv-7ay-1@gated-at.bofh.it> (permalink) |
| References | <rx0rx-4yi-11@gated-at.bofh.it> <rx0rx-4yi-21@gated-at.bofh.it> <rxjku-6P9-13@gated-at.bofh.it> <rxjku-6P9-11@gated-at.bofh.it> <rxjDR-75T-27@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 05/10/2016 10:26 AM, Borislav Petkov wrote: >> > It's nice to dump out interesting data in dmesg, but I'm curious why you >> > think it's interesting. > I think it would be interesting to know what the kernel's idea > is of user_xstate_size. I know, I know, one can follow the code > and figure out what it is but one can say the same about a lot of > other "interesting" data dumped in dmesg. And I'd like to know what > fpu__init_system_xstate_size_legacy() decided. And so I know how many > data is shuffled to/from userspace. > > And btw, this message needs more "humanization": > > [ 0.000000] x86/fpu: xstate_offset[2]: 576, xstate_sizes[2]: 256 > > That doesn't tell me anything. > > Oh and it can be read out from CPUID too. That all sounds like great stuff to do in a follow-on patchset after this XSAVES stuff.
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v5 02/13] x86/xsaves: Rename xstate_size to kernel_xstate_size to explicitly distinguish xstate size in kernel from user space Yu-cheng Yu <yu-cheng.yu@intel.com> - 2016-05-09 23:00 +0200
Re: [PATCH v5 02/13] x86/xsaves: Rename xstate_size to kernel_xstate_size to explicitly distinguish xstate size in kernel from user space Dave Hansen <dave.hansen@linux.intel.com> - 2016-05-10 19:10 +0200
Re: [PATCH v5 02/13] x86/xsaves: Rename xstate_size to kernel_xstate_size to explicitly distinguish xstate size in kernel from user space Borislav Petkov <bp@suse.de> - 2016-05-10 19:30 +0200
Re: [PATCH v5 02/13] x86/xsaves: Rename xstate_size to kernel_xstate_size to explicitly distinguish xstate size in kernel from user space Dave Hansen <dave.hansen@linux.intel.com> - 2016-05-10 19:40 +0200
Re: [PATCH v5 02/13] x86/xsaves: Rename xstate_size to kernel_xstate_size to explicitly distinguish xstate size in kernel from user space Borislav Petkov <bp@suse.de> - 2016-05-10 19:10 +0200
csiph-web