Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1398350

Re: [PATCH v5 02/13] x86/xsaves: Rename xstate_size to kernel_xstate_size to explicitly distinguish xstate size in kernel from user space

From Borislav Petkov <bp@suse.de>
Newsgroups linux.kernel
Subject Re: [PATCH v5 02/13] x86/xsaves: Rename xstate_size to kernel_xstate_size to explicitly distinguish xstate size in kernel from user space
Date 2016-05-10 19:30 +0200
Message-ID <rxjDR-75T-27@gated-at.bofh.it> (permalink)
References <rx0rx-4yi-11@gated-at.bofh.it> <rx0rx-4yi-21@gated-at.bofh.it> <rxjku-6P9-13@gated-at.bofh.it> <rxjku-6P9-11@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Tue, May 10, 2016 at 10:08:44AM -0700, Dave Hansen wrote:
> But the kernel never actually stores "user_xstate_size" anywhere or
> really ever even cares about it except when copying in/out of userspace.

Sounds like a reason enough to me.

> "user_xstate_size" is also entirely enumerable in userspace with a
> single cpuid instruction.

So is a lot of other stuff we're dumping in dmesg.

> It's nice to dump out interesting data in dmesg, but I'm curious why you
> think it's interesting.

I think it would be interesting to know what the kernel's idea
is of user_xstate_size. I know, I know, one can follow the code
and figure out what it is but one can say the same about a lot of
other "interesting" data dumped in dmesg. And I'd like to know what
fpu__init_system_xstate_size_legacy() decided. And so I know how many
data is shuffled to/from userspace.

And btw, this message needs more "humanization":

[    0.000000] x86/fpu: xstate_offset[2]:  576, xstate_sizes[2]:  256

That doesn't tell me anything.

Oh and it can be read out from CPUID too.

-- 
Regards/Gruss,
    Boris.

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284 (AG Nürnberg)
-- 

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v5 02/13] x86/xsaves: Rename xstate_size to kernel_xstate_size to explicitly distinguish xstate size in kernel from user space Yu-cheng Yu <yu-cheng.yu@intel.com> - 2016-05-09 23:00 +0200
  Re: [PATCH v5 02/13] x86/xsaves: Rename xstate_size to  kernel_xstate_size to explicitly distinguish xstate size in kernel from user  space Dave Hansen <dave.hansen@linux.intel.com> - 2016-05-10 19:10 +0200
    Re: [PATCH v5 02/13] x86/xsaves: Rename xstate_size to  kernel_xstate_size to explicitly distinguish xstate size in kernel from user  space Borislav Petkov <bp@suse.de> - 2016-05-10 19:30 +0200
      Re: [PATCH v5 02/13] x86/xsaves: Rename xstate_size to  kernel_xstate_size to explicitly distinguish xstate size in kernel from user  space Dave Hansen <dave.hansen@linux.intel.com> - 2016-05-10 19:40 +0200
  Re: [PATCH v5 02/13] x86/xsaves: Rename xstate_size to  kernel_xstate_size to explicitly distinguish xstate size in kernel from user  space Borislav Petkov <bp@suse.de> - 2016-05-10 19:10 +0200

csiph-web