Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1381900
| From | Kees Cook <keescook@chromium.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 0/6] x86, boot: clean up KASLR code |
| Date | 2016-04-18 18:50 +0200 |
| Message-ID | <rpkx3-lO-3@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
In order to make improvements to KASLR behavior, it has been suggested that the code should be cleaned up a bit first. This is the start of those changes. Since there are no stand-alone bug fixes in the later patches, I will begin here. First with a rename followed by variable name changes and comment improvements. This is the first wave... -Kees
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH 0/6] x86, boot: clean up KASLR code Kees Cook <keescook@chromium.org> - 2016-04-18 18:50 +0200
[PATCH 1/6] x86, KASLR: rename aslr.c to kaslr.c Kees Cook <keescook@chromium.org> - 2016-04-18 18:50 +0200
[tip:x86/boot] x86/KASLR: Rename aslr.c to kaslr.c tip-bot for Kees Cook <tipbot@zytor.com> - 2016-04-19 11:40 +0200
[PATCH 5/6] x86, KASLR: Clarify purpose of kaslr.c Kees Cook <keescook@chromium.org> - 2016-04-18 18:50 +0200
[tip:x86/boot] x86/KASLR: Clarify purpose of kaslr.c tip-bot for Kees Cook <tipbot@zytor.com> - 2016-04-19 11:40 +0200
[PATCH 4/6] x86, boot: Clarify purpose of functions in misc.c Kees Cook <keescook@chromium.org> - 2016-04-18 18:50 +0200
[tip:x86/boot] x86/boot: Clarify purpose of functions in misc.c tip-bot for Kees Cook <tipbot@zytor.com> - 2016-04-19 11:40 +0200
[PATCH 6/6] x86, KASLR: Rename "random" to "random_addr" Kees Cook <keescook@chromium.org> - 2016-04-18 18:50 +0200
[tip:x86/boot] x86/KASLR: Rename "random" to "random_addr" tip-bot for Kees Cook <tipbot@zytor.com> - 2016-04-19 11:40 +0200
Re: [PATCH 0/6] x86, boot: clean up KASLR code Ingo Molnar <mingo@kernel.org> - 2016-04-19 10:40 +0200
csiph-web