Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1382327

[tip:x86/boot] x86/KASLR: Rename aslr.c to kaslr.c

From tip-bot for Kees Cook <tipbot@zytor.com>
Newsgroups linux.kernel
Subject [tip:x86/boot] x86/KASLR: Rename aslr.c to kaslr.c
Date 2016-04-19 11:40 +0200
Message-ID <rpAiv-4BY-25@gated-at.bofh.it> (permalink)
References <rpkx4-lO-17@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Commit-ID:  9b238748cb6e9fadab0e761f6d30ba311b4ac470
Gitweb:     http://git.kernel.org/tip/9b238748cb6e9fadab0e761f6d30ba311b4ac470
Author:     Kees Cook <keescook@chromium.org>
AuthorDate: Mon, 18 Apr 2016 09:42:10 -0700
Committer:  Ingo Molnar <mingo@kernel.org>
CommitDate: Tue, 19 Apr 2016 10:30:50 +0200

x86/KASLR: Rename aslr.c to kaslr.c

In order to avoid confusion over what this file provides, rename it to
kaslr.c since it is used exclusively for the kernel ASLR, not userspace
ASLR.

Suggested-by: Ingo Molnar <mingo@kernel.org>
Signed-off-by: Kees Cook <keescook@chromium.org>
Cc: Andrew Morton <akpm@linux-foundation.org>
Cc: Andrey Ryabinin <aryabinin@virtuozzo.com>
Cc: Andy Lutomirski <luto@amacapital.net>
Cc: Andy Lutomirski <luto@kernel.org>
Cc: Baoquan He <bhe@redhat.com>
Cc: Borislav Petkov <bp@alien8.de>
Cc: Borislav Petkov <bp@suse.de>
Cc: Brian Gerst <brgerst@gmail.com>
Cc: Denys Vlasenko <dvlasenk@redhat.com>
Cc: Dmitry Vyukov <dvyukov@google.com>
Cc: H. Peter Anvin <hpa@zytor.com>
Cc: H.J. Lu <hjl.tools@gmail.com>
Cc: Josh Poimboeuf <jpoimboe@redhat.com>
Cc: Linus Torvalds <torvalds@linux-foundation.org>
Cc: Peter Zijlstra <peterz@infradead.org>
Cc: Thomas Gleixner <tglx@linutronix.de>
Cc: Yinghai Lu <yinghai@kernel.org>
Link: http://lkml.kernel.org/r/1460997735-24785-2-git-send-email-keescook@chromium.org
Signed-off-by: Ingo Molnar <mingo@kernel.org>
---
 arch/x86/boot/compressed/Makefile            | 2 +-
 arch/x86/boot/compressed/{aslr.c => kaslr.c} | 0
 arch/x86/boot/compressed/misc.h              | 2 +-
 3 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/x86/boot/compressed/Makefile b/arch/x86/boot/compressed/Makefile
index 8774cb2..542c92f 100644
--- a/arch/x86/boot/compressed/Makefile
+++ b/arch/x86/boot/compressed/Makefile
@@ -62,7 +62,7 @@ vmlinux-objs-y := $(obj)/vmlinux.lds $(obj)/head_$(BITS).o $(obj)/misc.o \
 	$(obj)/piggy.o $(obj)/cpuflags.o
 
 vmlinux-objs-$(CONFIG_EARLY_PRINTK) += $(obj)/early_serial_console.o
-vmlinux-objs-$(CONFIG_RANDOMIZE_BASE) += $(obj)/aslr.o
+vmlinux-objs-$(CONFIG_RANDOMIZE_BASE) += $(obj)/kaslr.o
 
 $(obj)/eboot.o: KBUILD_CFLAGS += -fshort-wchar -mno-red-zone
 
diff --git a/arch/x86/boot/compressed/aslr.c b/arch/x86/boot/compressed/kaslr.c
similarity index 100%
rename from arch/x86/boot/compressed/aslr.c
rename to arch/x86/boot/compressed/kaslr.c
diff --git a/arch/x86/boot/compressed/misc.h b/arch/x86/boot/compressed/misc.h
index 3783dc3..a8c4e08 100644
--- a/arch/x86/boot/compressed/misc.h
+++ b/arch/x86/boot/compressed/misc.h
@@ -66,7 +66,7 @@ int cmdline_find_option_bool(const char *option);
 
 
 #if CONFIG_RANDOMIZE_BASE
-/* aslr.c */
+/* kaslr.c */
 unsigned char *choose_kernel_location(struct boot_params *boot_params,
 				      unsigned char *input,
 				      unsigned long input_size,

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 0/6] x86, boot: clean up KASLR code Kees Cook <keescook@chromium.org> - 2016-04-18 18:50 +0200
  [PATCH 1/6] x86, KASLR: rename aslr.c to kaslr.c Kees Cook <keescook@chromium.org> - 2016-04-18 18:50 +0200
    [tip:x86/boot] x86/KASLR: Rename aslr.c to kaslr.c tip-bot for Kees Cook <tipbot@zytor.com> - 2016-04-19 11:40 +0200
  [PATCH 5/6] x86, KASLR: Clarify purpose of kaslr.c Kees Cook <keescook@chromium.org> - 2016-04-18 18:50 +0200
    [tip:x86/boot] x86/KASLR: Clarify purpose of kaslr.c tip-bot for Kees Cook <tipbot@zytor.com> - 2016-04-19 11:40 +0200
  [PATCH 4/6] x86, boot: Clarify purpose of functions in misc.c Kees Cook <keescook@chromium.org> - 2016-04-18 18:50 +0200
    [tip:x86/boot] x86/boot: Clarify purpose of functions in misc.c tip-bot for Kees Cook <tipbot@zytor.com> - 2016-04-19 11:40 +0200
  [PATCH 6/6] x86, KASLR: Rename "random" to "random_addr" Kees Cook <keescook@chromium.org> - 2016-04-18 18:50 +0200
    [tip:x86/boot] x86/KASLR: Rename "random" to "random_addr" tip-bot for Kees Cook <tipbot@zytor.com> - 2016-04-19 11:40 +0200
  Re: [PATCH 0/6] x86, boot: clean up KASLR code Ingo Molnar <mingo@kernel.org> - 2016-04-19 10:40 +0200

csiph-web