Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1382328
| From | tip-bot for Kees Cook <tipbot@zytor.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [tip:x86/boot] x86/KASLR: Rename "random" to "random_addr" |
| Date | 2016-04-19 11:40 +0200 |
| Message-ID | <rpAiv-4BY-31@gated-at.bofh.it> (permalink) |
| References | <rpkx5-lO-33@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Commit-ID: 9016875df408fc5db6a94a3c5f5f5503c916cf81
Gitweb: http://git.kernel.org/tip/9016875df408fc5db6a94a3c5f5f5503c916cf81
Author: Kees Cook <keescook@chromium.org>
AuthorDate: Mon, 18 Apr 2016 09:42:15 -0700
Committer: Ingo Molnar <mingo@kernel.org>
CommitDate: Tue, 19 Apr 2016 10:30:51 +0200
x86/KASLR: Rename "random" to "random_addr"
The variable "random" is also the name of a libc function. It's better
coding style to avoid overloading such things, so rename it to the more
accurate "random_addr".
Suggested-by: Ingo Molnar <mingo@kernel.org>
Signed-off-by: Kees Cook <keescook@chromium.org>
Cc: Andrew Morton <akpm@linux-foundation.org>
Cc: Andrey Ryabinin <aryabinin@virtuozzo.com>
Cc: Andy Lutomirski <luto@amacapital.net>
Cc: Andy Lutomirski <luto@kernel.org>
Cc: Baoquan He <bhe@redhat.com>
Cc: Borislav Petkov <bp@alien8.de>
Cc: Borislav Petkov <bp@suse.de>
Cc: Brian Gerst <brgerst@gmail.com>
Cc: Denys Vlasenko <dvlasenk@redhat.com>
Cc: Dmitry Vyukov <dvyukov@google.com>
Cc: H. Peter Anvin <hpa@zytor.com>
Cc: H.J. Lu <hjl.tools@gmail.com>
Cc: Josh Poimboeuf <jpoimboe@redhat.com>
Cc: Linus Torvalds <torvalds@linux-foundation.org>
Cc: Peter Zijlstra <peterz@infradead.org>
Cc: Thomas Gleixner <tglx@linutronix.de>
Cc: Yinghai Lu <yinghai@kernel.org>
Link: http://lkml.kernel.org/r/1460997735-24785-7-git-send-email-keescook@chromium.org
Signed-off-by: Ingo Molnar <mingo@kernel.org>
---
arch/x86/boot/compressed/kaslr.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/arch/x86/boot/compressed/kaslr.c b/arch/x86/boot/compressed/kaslr.c
index 9e03190..9c29e78 100644
--- a/arch/x86/boot/compressed/kaslr.c
+++ b/arch/x86/boot/compressed/kaslr.c
@@ -312,7 +312,7 @@ unsigned char *choose_random_location(unsigned char *input,
unsigned long output_size)
{
unsigned long choice = (unsigned long)output;
- unsigned long random;
+ unsigned long random_addr;
#ifdef CONFIG_HIBERNATION
if (!cmdline_find_option_bool("kaslr")) {
@@ -333,17 +333,17 @@ unsigned char *choose_random_location(unsigned char *input,
(unsigned long)output, output_size);
/* Walk e820 and find a random address. */
- random = find_random_addr(choice, output_size);
- if (!random) {
+ random_addr = find_random_addr(choice, output_size);
+ if (!random_addr) {
debug_putstr("KASLR could not find suitable E820 region...\n");
goto out;
}
/* Always enforce the minimum. */
- if (random < choice)
+ if (random_addr < choice)
goto out;
- choice = random;
+ choice = random_addr;
out:
return (unsigned char *)choice;
}
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 0/6] x86, boot: clean up KASLR code Kees Cook <keescook@chromium.org> - 2016-04-18 18:50 +0200
[PATCH 1/6] x86, KASLR: rename aslr.c to kaslr.c Kees Cook <keescook@chromium.org> - 2016-04-18 18:50 +0200
[tip:x86/boot] x86/KASLR: Rename aslr.c to kaslr.c tip-bot for Kees Cook <tipbot@zytor.com> - 2016-04-19 11:40 +0200
[PATCH 5/6] x86, KASLR: Clarify purpose of kaslr.c Kees Cook <keescook@chromium.org> - 2016-04-18 18:50 +0200
[tip:x86/boot] x86/KASLR: Clarify purpose of kaslr.c tip-bot for Kees Cook <tipbot@zytor.com> - 2016-04-19 11:40 +0200
[PATCH 4/6] x86, boot: Clarify purpose of functions in misc.c Kees Cook <keescook@chromium.org> - 2016-04-18 18:50 +0200
[tip:x86/boot] x86/boot: Clarify purpose of functions in misc.c tip-bot for Kees Cook <tipbot@zytor.com> - 2016-04-19 11:40 +0200
[PATCH 6/6] x86, KASLR: Rename "random" to "random_addr" Kees Cook <keescook@chromium.org> - 2016-04-18 18:50 +0200
[tip:x86/boot] x86/KASLR: Rename "random" to "random_addr" tip-bot for Kees Cook <tipbot@zytor.com> - 2016-04-19 11:40 +0200
Re: [PATCH 0/6] x86, boot: clean up KASLR code Ingo Molnar <mingo@kernel.org> - 2016-04-19 10:40 +0200
csiph-web