Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1363372
| From | Mel Gorman <mgorman@techsingularity.net> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 4/5] mm/lru: is_file/active_lru can be boolean |
| Date | 2016-03-23 12:50 +0100 |
| Message-ID | <rfPsu-2Nq-13@gated-at.bofh.it> (permalink) |
| References | <rfGIx-54a-7@gated-at.bofh.it> <rfGIx-54a-5@gated-at.bofh.it> <rfHuV-5OI-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, Mar 22, 2016 at 08:17:08PM -0700, Joe Perches wrote: > On Wed, 2016-03-23 at 10:26 +0800, Yaowei Bai wrote: > > This patch makes is_file/active_lru return bool to improve > > readability due to these particular functions only using either > > one or zero as their return value. > > > > No functional change. > > These assignments to int should likely be modified too > Which would lead to oddities as the ints are used as offsets within enums. Patch 2 has a problem where a bool is then used as part of a bitmask operation. I stopped looking fairly early on. Conversions from int to bool as part of a cleanup-only series are almost never useful and sometimes introduce subtle breakage. It is only worth the conversion when the helper is being modified for some other purpose. On that grounds, NAK to the whole series as small problems were quickly obvious and it's not worth the brainpower to find all the problems when the end result does not give us a tangible improvement. -- Mel Gorman SUSE Labs
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 4/5] mm/lru: is_file/active_lru can be boolean Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2016-03-23 03:30 +0100
Re: [PATCH 4/5] mm/lru: is_file/active_lru can be boolean Joe Perches <joe@perches.com> - 2016-03-23 04:20 +0100
Re: [PATCH 4/5] mm/lru: is_file/active_lru can be boolean Mel Gorman <mgorman@techsingularity.net> - 2016-03-23 12:50 +0100
csiph-web