Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1363168

[PATCH 4/5] mm/lru: is_file/active_lru can be boolean

From Yaowei Bai <baiyaowei@cmss.chinamobile.com>
Newsgroups linux.kernel
Subject [PATCH 4/5] mm/lru: is_file/active_lru can be boolean
Date 2016-03-23 03:30 +0100
Message-ID <rfGIx-54a-5@gated-at.bofh.it> (permalink)
References <rfGIx-54a-7@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


This patch makes is_file/active_lru return bool to improve
readability due to these particular functions only using either
one or zero as their return value.

No functional change.

Signed-off-by: Yaowei Bai <baiyaowei@cmss.chinamobile.com>
---
 include/linux/mmzone.h | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h
index 6de02ac3..652d60e 100644
--- a/include/linux/mmzone.h
+++ b/include/linux/mmzone.h
@@ -188,12 +188,12 @@ enum lru_list {
 
 #define for_each_evictable_lru(lru) for (lru = 0; lru <= LRU_ACTIVE_FILE; lru++)
 
-static inline int is_file_lru(enum lru_list lru)
+static inline bool is_file_lru(enum lru_list lru)
 {
 	return (lru == LRU_INACTIVE_FILE || lru == LRU_ACTIVE_FILE);
 }
 
-static inline int is_active_lru(enum lru_list lru)
+static inline bool is_active_lru(enum lru_list lru)
 {
 	return (lru == LRU_ACTIVE_ANON || lru == LRU_ACTIVE_FILE);
 }
-- 
1.9.1

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[PATCH 4/5] mm/lru: is_file/active_lru can be boolean Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2016-03-23 03:30 +0100
  Re: [PATCH 4/5] mm/lru: is_file/active_lru can be boolean Joe Perches <joe@perches.com> - 2016-03-23 04:20 +0100
    Re: [PATCH 4/5] mm/lru: is_file/active_lru can be boolean Mel Gorman <mgorman@techsingularity.net> - 2016-03-23 12:50 +0100

csiph-web