Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1363186
| From | Joe Perches <joe@perches.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 4/5] mm/lru: is_file/active_lru can be boolean |
| Date | 2016-03-23 04:20 +0100 |
| Message-ID | <rfHuV-5OI-3@gated-at.bofh.it> (permalink) |
| References | <rfGIx-54a-7@gated-at.bofh.it> <rfGIx-54a-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Wed, 2016-03-23 at 10:26 +0800, Yaowei Bai wrote: > This patch makes is_file/active_lru return bool to improve > readability due to these particular functions only using either > one or zero as their return value. > > No functional change. These assignments to int should likely be modified too $ git grep -w -n is_file_lru include/linux/mmzone.h:191:static inline int is_file_lru(enum lru_list lru) mm/vmscan.c:1404: nr_taken, mode, is_file_lru(lru)); mm/vmscan.c:1525: int file = is_file_lru(lru); mm/vmscan.c:1581: int file = is_file_lru(lru); mm/vmscan.c:1783: int file = is_file_lru(lru); mm/vmscan.c:1934: if (is_file_lru(lru)) mm/vmscan.c:2129: int file = is_file_lru(lru);
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 4/5] mm/lru: is_file/active_lru can be boolean Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2016-03-23 03:30 +0100
Re: [PATCH 4/5] mm/lru: is_file/active_lru can be boolean Joe Perches <joe@perches.com> - 2016-03-23 04:20 +0100
Re: [PATCH 4/5] mm/lru: is_file/active_lru can be boolean Mel Gorman <mgorman@techsingularity.net> - 2016-03-23 12:50 +0100
csiph-web