Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1439079

Re: [PATCH v7 09/11] cpuidle/powernv: cleanup powernv_add_idle_states

From Michael Neuling <mikey@neuling.org>
Newsgroups linux.kernel
Subject Re: [PATCH v7 09/11] cpuidle/powernv: cleanup powernv_add_idle_states
Date 2016-07-08 04:50 +0200
Message-ID <rSu1z-76m-7@gated-at.bofh.it> (permalink)
References <rSopb-3tL-1@gated-at.bofh.it> <rSopc-3tL-31@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


>  		/*
> @@ -230,7 +238,7 @@ static int powernv_add_idle_states(void)
>  			strcpy(powernv_states[nr_idle_states].desc, "FastSleep");
>  			powernv_states[nr_idle_states].flags = CPUIDLE_FLAG_TIMER_STOP;
>  			powernv_states[nr_idle_states].target_residency = 300000;
> -			powernv_states[nr_idle_states].enter = &fastsleep_loop;
> +			powernv_states[nr_idle_states].enter = fastsleep_loop;

You can change this code too with the same thing.

static struct cpuidle_state powernv_states[CPUIDLE_STATE_MAX] = {
	{ /* Snooze */
		.name = "snooze",
		.desc = "snooze",
		.exit_latency = 0,
		.target_residency = 0,
		.enter = &snooze_loop },
};

Mikey

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v7 00/11] powerpc/powernv/cpuidle: Add support for POWER ISA v3 idle states "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 01/11] powerpc/powernv: Use PNV_THREAD_WINKLE macro while requesting for winkle "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 08/11] cpuidle/powernv: Use CPUIDLE_STATE_MAX instead of MAX_POWERNV_IDLE_STATES "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 07/11] powerpc/powernv: Add platform support for stop instruction "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
    Re: [PATCH v7 07/11] powerpc/powernv: Add platform support for stop  instruction Michael Neuling <mikey@neuling.org> - 2016-07-08 04:30 +0200
      Re: [PATCH v7 07/11] powerpc/powernv: Add platform support for stop  instruction Shreyas B Prabhu <shreyas@linux.vnet.ibm.com> - 2016-07-08 06:30 +0200
        Re: [PATCH v7 07/11] powerpc/powernv: Add platform support for stop  instruction Michael Neuling <mikey@neuling.org> - 2016-07-08 06:30 +0200
  [PATCH v7 10/11] cpuidle/powernv: Add support for POWER ISA v3 idle states "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 02/11] powerpc/kvm: make hypervisor state restore a function "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 09/11] cpuidle/powernv: cleanup powernv_add_idle_states "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
    Re: [PATCH v7 09/11] cpuidle/powernv: cleanup  powernv_add_idle_states Michael Neuling <mikey@neuling.org> - 2016-07-08 04:50 +0200
  [PATCH v7 03/11] powerpc/powernv: Rename idle_power7.S to idle_book3s.S "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 04/11] powerpc/powernv: Rename reusable idle functions to hardware agnostic names "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 06/11] powerpc/powernv: abstraction for saving SPRs before entering deep idle states "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 05/11] powerpc/powernv: Make pnv_powersave_common more generic "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 23:00 +0200
  Re: [PATCH v7 00/11] powerpc/powernv/cpuidle: Add support for POWER  ISA v3 idle states Michael Neuling <mikey@neuling.org> - 2016-07-08 04:50 +0200

csiph-web