Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1438928

[PATCH v7 08/11] cpuidle/powernv: Use CPUIDLE_STATE_MAX instead of MAX_POWERNV_IDLE_STATES

From "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com>
Newsgroups linux.kernel
Subject [PATCH v7 08/11] cpuidle/powernv: Use CPUIDLE_STATE_MAX instead of MAX_POWERNV_IDLE_STATES
Date 2016-07-07 22:50 +0200
Message-ID <rSopc-3tL-19@gated-at.bofh.it> (permalink)
References <rSopb-3tL-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Use cpuidle's CPUIDLE_STATE_MAX macro instead of powernv specific
MAX_POWERNV_IDLE_STATES.

Cc: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
Cc: Daniel Lezcano <daniel.lezcano@linaro.org>
Cc: linux-pm@vger.kernel.org
Acked-by: Daniel Lezcano <daniel.lezcano@linaro.org>
Signed-off-by: Shreyas B. Prabhu <shreyas@linux.vnet.ibm.com>
---
 - No changes after v5

Changes in v5
=============
 - New in v5

 drivers/cpuidle/cpuidle-powernv.c | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

diff --git a/drivers/cpuidle/cpuidle-powernv.c b/drivers/cpuidle/cpuidle-powernv.c
index e12dc30..3a763a8 100644
--- a/drivers/cpuidle/cpuidle-powernv.c
+++ b/drivers/cpuidle/cpuidle-powernv.c
@@ -20,8 +20,6 @@
 #include <asm/opal.h>
 #include <asm/runlatch.h>
 
-#define MAX_POWERNV_IDLE_STATES	8
-
 struct cpuidle_driver powernv_idle_driver = {
 	.name             = "powernv_idle",
 	.owner            = THIS_MODULE,
@@ -96,7 +94,7 @@ static int fastsleep_loop(struct cpuidle_device *dev,
 /*
  * States for dedicated partition case.
  */
-static struct cpuidle_state powernv_states[MAX_POWERNV_IDLE_STATES] = {
+static struct cpuidle_state powernv_states[CPUIDLE_STATE_MAX] = {
 	{ /* Snooze */
 		.name = "snooze",
 		.desc = "snooze",
-- 
2.4.11

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v7 00/11] powerpc/powernv/cpuidle: Add support for POWER ISA v3 idle states "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 01/11] powerpc/powernv: Use PNV_THREAD_WINKLE macro while requesting for winkle "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 08/11] cpuidle/powernv: Use CPUIDLE_STATE_MAX instead of MAX_POWERNV_IDLE_STATES "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 07/11] powerpc/powernv: Add platform support for stop instruction "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
    Re: [PATCH v7 07/11] powerpc/powernv: Add platform support for stop  instruction Michael Neuling <mikey@neuling.org> - 2016-07-08 04:30 +0200
      Re: [PATCH v7 07/11] powerpc/powernv: Add platform support for stop  instruction Shreyas B Prabhu <shreyas@linux.vnet.ibm.com> - 2016-07-08 06:30 +0200
        Re: [PATCH v7 07/11] powerpc/powernv: Add platform support for stop  instruction Michael Neuling <mikey@neuling.org> - 2016-07-08 06:30 +0200
  [PATCH v7 10/11] cpuidle/powernv: Add support for POWER ISA v3 idle states "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 02/11] powerpc/kvm: make hypervisor state restore a function "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 09/11] cpuidle/powernv: cleanup powernv_add_idle_states "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
    Re: [PATCH v7 09/11] cpuidle/powernv: cleanup  powernv_add_idle_states Michael Neuling <mikey@neuling.org> - 2016-07-08 04:50 +0200
  [PATCH v7 03/11] powerpc/powernv: Rename idle_power7.S to idle_book3s.S "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 04/11] powerpc/powernv: Rename reusable idle functions to hardware agnostic names "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 06/11] powerpc/powernv: abstraction for saving SPRs before entering deep idle states "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 05/11] powerpc/powernv: Make pnv_powersave_common more generic "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 23:00 +0200
  Re: [PATCH v7 00/11] powerpc/powernv/cpuidle: Add support for POWER  ISA v3 idle states Michael Neuling <mikey@neuling.org> - 2016-07-08 04:50 +0200

csiph-web