Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1438925

[PATCH v7 01/11] powerpc/powernv: Use PNV_THREAD_WINKLE macro while requesting for winkle

From "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com>
Newsgroups linux.kernel
Subject [PATCH v7 01/11] powerpc/powernv: Use PNV_THREAD_WINKLE macro while requesting for winkle
Date 2016-07-07 22:50 +0200
Message-ID <rSopb-3tL-5@gated-at.bofh.it> (permalink)
References <rSopb-3tL-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Signed-off-by: Shreyas B. Prabhu <shreyas@linux.vnet.ibm.com>
---
-No changes since v4

Changes in v4
=============
- New in v4

 arch/powerpc/kernel/idle_power7.S | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/arch/powerpc/kernel/idle_power7.S b/arch/powerpc/kernel/idle_power7.S
index 470ceeb..705c867 100644
--- a/arch/powerpc/kernel/idle_power7.S
+++ b/arch/powerpc/kernel/idle_power7.S
@@ -252,7 +252,7 @@ _GLOBAL(power7_sleep)
 	/* No return */
 
 _GLOBAL(power7_winkle)
-	li	r3,3
+	li	r3,PNV_THREAD_WINKLE
 	li	r4,1
 	b	power7_powersave_common
 	/* No return */
-- 
2.4.11

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v7 00/11] powerpc/powernv/cpuidle: Add support for POWER ISA v3 idle states "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 01/11] powerpc/powernv: Use PNV_THREAD_WINKLE macro while requesting for winkle "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 08/11] cpuidle/powernv: Use CPUIDLE_STATE_MAX instead of MAX_POWERNV_IDLE_STATES "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 07/11] powerpc/powernv: Add platform support for stop instruction "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
    Re: [PATCH v7 07/11] powerpc/powernv: Add platform support for stop  instruction Michael Neuling <mikey@neuling.org> - 2016-07-08 04:30 +0200
      Re: [PATCH v7 07/11] powerpc/powernv: Add platform support for stop  instruction Shreyas B Prabhu <shreyas@linux.vnet.ibm.com> - 2016-07-08 06:30 +0200
        Re: [PATCH v7 07/11] powerpc/powernv: Add platform support for stop  instruction Michael Neuling <mikey@neuling.org> - 2016-07-08 06:30 +0200
  [PATCH v7 10/11] cpuidle/powernv: Add support for POWER ISA v3 idle states "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 02/11] powerpc/kvm: make hypervisor state restore a function "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 09/11] cpuidle/powernv: cleanup powernv_add_idle_states "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
    Re: [PATCH v7 09/11] cpuidle/powernv: cleanup  powernv_add_idle_states Michael Neuling <mikey@neuling.org> - 2016-07-08 04:50 +0200
  [PATCH v7 03/11] powerpc/powernv: Rename idle_power7.S to idle_book3s.S "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 04/11] powerpc/powernv: Rename reusable idle functions to hardware agnostic names "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 06/11] powerpc/powernv: abstraction for saving SPRs before entering deep idle states "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 22:50 +0200
  [PATCH v7 05/11] powerpc/powernv: Make pnv_powersave_common more generic "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-07-07 23:00 +0200
  Re: [PATCH v7 00/11] powerpc/powernv/cpuidle: Add support for POWER  ISA v3 idle states Michael Neuling <mikey@neuling.org> - 2016-07-08 04:50 +0200

csiph-web