Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1437552
| From | luca abeni <luca.abeni@unitn.it> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2] sched/deadline: remove useless param from setup_new_dl_entity |
| Date | 2016-07-06 10:50 +0200 |
| Message-ID | <rRQGS-6SL-27@gated-at.bofh.it> (permalink) |
| References | <rPt22-85k-13@gated-at.bofh.it> <rRzwn-3YJ-43@gated-at.bofh.it> <rRzG1-436-3@gated-at.bofh.it> <rRBHR-5kY-53@gated-at.bofh.it> <rRBRv-5oU-1@gated-at.bofh.it> |
| Organization | university of trento |
On Tue, 5 Jul 2016 17:58:30 +0100 Juri Lelli <juri.lelli@arm.com> wrote: > On 05/07/16 12:47, Steven Rostedt wrote: > > On Tue, 5 Jul 2016 15:39:33 +0100 > > Juri Lelli <juri.lelli@arm.com> wrote: > > > > return; > > > > > > > > > > /* > > > > > + * Use the scheduling parameters of the top > > > > > pi-waiter task, > > > > > + * if we have one from which we can inherit a > > > > > deadline. > > > > > + */ > > > > > + if (pi_task && dl_se->dl_boosted && > > > > > dl_prio(pi_task->normal_prio)) > > > > > + pi_se = &pi_task->dl; > > > > > + > > > > > > > > OK, I'm micro-optimizing now, but hey, isn't this a fast path? > > > > > > > > What about changing the above to: > > > > > > > > struct task_struct *pi_task; > > > > [...] > > > > > > > > if (dl_se->dl_boosted && dl_prio(pi_task->normal_prio > > > > && > > > ^ > > > OK, we need to reorder these two > > > V > > > > (pi_task = rt_mutex_get_top_task(dl_task_of(dl_se))) > > > > pe_se = &pi_task->dl; > > > > Opps, you're right. > > > > > > > > > > This way we don't need to do any work of looking at > > > > rt_mutex_get_top_task() for the normal case. > > > > > > > > > > But, yes. Looks good to me. I'll shoot a v3 ASAP. > > > > I have to ask, should there be any check if the dl_se has a shorter > > deadline than the pi one? > > > > Yeah. I wondered the same actually. I convinced myself that, since the > task is boosted, we assume that the donor will have a shorter > deadline. Do you mean relative deadline (dl_se->dl_deadline) or absolute (scheduling) dealine (dl_se->deadline)? If I understand well, here we are in setup_new_dl_entity(), right? This should be called only from switched_to_dl(); so, dl_se is from a task that is switching to -deadline. If it is dl_boosted, it means that it is switching from SCHED_OTHER (or RT) to -deadline because of inheritance... So, it is very likely that dl_se->dl_deadline is not meaningful. Moreover, setup_new_dl_entity() is only called if the current scheduling deadline of the task is not usable (that is, if "dl_time_before(p->dl.deadline, rq_clock(rq)"). So, dl_se->deadline will be surely smaller than pi_se->deadline... But the inheritance has to happen anyway. > We seem to be doing the same elsewhere, but Luca was saying > some time ago that the DI thing my have some problems and needs to be > revised. My doubts regarding the inheritance code currently used for -deadline tasks are due to the fact that it is not clear which kind of inheritance algorithm is used... I think it should use deadline inheritance, that, AFAIK, says that when task T1 block waiting for task T2, T2 can inherit T1's _absolute_ deadline - if it is earlier than T2's one. But the current code seems to be using relative deadlines (dl_deadline) to decide the inheritance... Having a better look at this is in my TODO list... But I still need to find some time :) Luca > Is is fair enough fixing this bit in accordance with the > current (maybe broken) behaviour and then spend time reviewing the > whole thing, or do we want to do both at the same time (which will of > course require more time)? > > Best, > > - Juri
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v2] sched/deadline: remove useless param from setup_new_dl_entity Juri Lelli <juri.lelli@arm.com> - 2016-06-29 21:10 +0200
Re: [PATCH v2] sched/deadline: remove useless param from setup_new_dl_entity luca abeni <luca.abeni@unitn.it> - 2016-07-04 11:10 +0200
Re: [PATCH v2] sched/deadline: remove useless param from setup_new_dl_entity Juri Lelli <juri.lelli@arm.com> - 2016-07-04 11:30 +0200
Re: [PATCH v2] sched/deadline: remove useless param from setup_new_dl_entity Wanpeng Li <kernellwp@gmail.com> - 2016-07-05 09:40 +0200
Re: [PATCH v2] sched/deadline: remove useless param from setup_new_dl_entity Juri Lelli <juri.lelli@arm.com> - 2016-07-05 11:00 +0200
Re: [PATCH v2] sched/deadline: remove useless param from setup_new_dl_entity Steven Rostedt <rostedt@goodmis.org> - 2016-07-05 16:30 +0200
Re: [PATCH v2] sched/deadline: remove useless param from setup_new_dl_entity Juri Lelli <juri.lelli@arm.com> - 2016-07-05 16:40 +0200
Re: [PATCH v2] sched/deadline: remove useless param from setup_new_dl_entity Steven Rostedt <rostedt@goodmis.org> - 2016-07-05 18:50 +0200
Re: [PATCH v2] sched/deadline: remove useless param from setup_new_dl_entity Juri Lelli <juri.lelli@arm.com> - 2016-07-05 19:00 +0200
Re: [PATCH v2] sched/deadline: remove useless param from setup_new_dl_entity luca abeni <luca.abeni@unitn.it> - 2016-07-06 10:50 +0200
Re: [PATCH v2] sched/deadline: remove useless param from setup_new_dl_entity Juri Lelli <juri.lelli@arm.com> - 2016-07-07 10:40 +0200
Re: [PATCH v2] sched/deadline: remove useless param from setup_new_dl_entity Steven Rostedt <rostedt@goodmis.org> - 2016-07-07 15:50 +0200
Re: [PATCH v2] sched/deadline: remove useless param from setup_new_dl_entity Juri Lelli <juri.lelli@arm.com> - 2016-07-08 13:40 +0200
Re: [PATCH v2] sched/deadline: remove useless param from setup_new_dl_entity luca abeni <luca.abeni@unitn.it> - 2016-07-06 10:50 +0200
csiph-web