Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1417228
| From | tip-bot for Borislav Petkov <tipbot@zytor.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [tip:x86/microcode] x86/microcode/AMD: Make amd_ucode_patch[] static |
| Date | 2016-06-08 12:00 +0200 |
| Message-ID | <rHIrh-6Wr-41@gated-at.bofh.it> (permalink) |
| References | <rH4tQ-6DT-35@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Commit-ID: a13004a2449c56a83d5816e81d850ea92b6837c2 Gitweb: http://git.kernel.org/tip/a13004a2449c56a83d5816e81d850ea92b6837c2 Author: Borislav Petkov <bp@suse.de> AuthorDate: Mon, 6 Jun 2016 17:10:49 +0200 Committer: Ingo Molnar <mingo@kernel.org> CommitDate: Wed, 8 Jun 2016 11:04:20 +0200 x86/microcode/AMD: Make amd_ucode_patch[] static It is used only in amd.c now. No functionality change. Signed-off-by: Borislav Petkov <bp@suse.de> Cc: Andy Lutomirski <luto@amacapital.net> Cc: Borislav Petkov <bp@alien8.de> Cc: Brian Gerst <brgerst@gmail.com> Cc: Denys Vlasenko <dvlasenk@redhat.com> Cc: H. Peter Anvin <hpa@zytor.com> Cc: Linus Torvalds <torvalds@linux-foundation.org> Cc: Peter Zijlstra <peterz@infradead.org> Cc: Thomas Gleixner <tglx@linutronix.de> Link: http://lkml.kernel.org/r/1465225850-7352-9-git-send-email-bp@alien8.de Signed-off-by: Ingo Molnar <mingo@kernel.org> --- arch/x86/include/asm/microcode_amd.h | 1 - arch/x86/kernel/cpu/microcode/amd.c | 2 +- 2 files changed, 1 insertion(+), 2 deletions(-) diff --git a/arch/x86/include/asm/microcode_amd.h b/arch/x86/include/asm/microcode_amd.h index adfc847..15eb754 100644 --- a/arch/x86/include/asm/microcode_amd.h +++ b/arch/x86/include/asm/microcode_amd.h @@ -62,7 +62,6 @@ extern int apply_microcode_amd(int cpu); extern enum ucode_state load_microcode_amd(int cpu, u8 family, const u8 *data, size_t size); #define PATCH_MAX_SIZE PAGE_SIZE -extern u8 amd_ucode_patch[PATCH_MAX_SIZE]; #ifdef CONFIG_MICROCODE_AMD extern void __init load_ucode_amd_bsp(unsigned int family); diff --git a/arch/x86/kernel/cpu/microcode/amd.c b/arch/x86/kernel/cpu/microcode/amd.c index b1d1e34..27a0228 100644 --- a/arch/x86/kernel/cpu/microcode/amd.c +++ b/arch/x86/kernel/cpu/microcode/amd.c @@ -56,7 +56,7 @@ static u8 *container; static size_t container_size; static u32 ucode_new_rev; -u8 amd_ucode_patch[PATCH_MAX_SIZE]; +static u8 amd_ucode_patch[PATCH_MAX_SIZE]; static u16 this_equiv_id; static struct cpio_data ucode_cpio;
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 0/9] x86/microcode: Fixes for builtin vs initrd loading; cleanups Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
[PATCH 7/9] x86/microcode/intel: Unexport save_mc_for_early() Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
[tip:x86/microcode] x86/microcode/intel: Unexport save_mc_for_early() tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-06-08 12:00 +0200
[PATCH 1/9] x86/microcode: Fix loading precedence Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
[tip:x86/microcode] x86/microcode: Fix loading precedence tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-06-08 12:00 +0200
[PATCH 6/9] x86/microcode/intel: Rename load_microcode_early() to find_microcode_patch() Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
[tip:x86/microcode] x86/microcode/intel: Rename load_microcode_early() to find_microcode_patch() tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-06-08 12:00 +0200
[PATCH 8/9] x86/microcode/AMD: Make amd_ucode_patch static Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
[tip:x86/microcode] x86/microcode/AMD: Make amd_ucode_patch[] static tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-06-08 12:00 +0200
[PATCH 9/9] Documentation/microcode: Document some aspects for more clarity Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
[tip:x86/microcode] Documentation/microcode: Document some aspects for more clarity tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-06-08 12:00 +0200
[PATCH 4/9] x86/microcode: Get rid of find_cpio_data()'s dummy offset arg Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
[tip:x86/microcode] x86/microcode: Get rid of find_cpio_data()'s dummy offset arg tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-06-08 12:00 +0200
[PATCH 3/9] lib/cpio: Make find_cpio_data()'s offset arg optional Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
[tip:x86/microcode] lib/cpio: Make find_cpio_data()'s offset arg optional tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-06-08 12:00 +0200
csiph-web