Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1415216

[PATCH 4/9] x86/microcode: Get rid of find_cpio_data()'s dummy offset arg

From Borislav Petkov <bp@alien8.de>
Newsgroups linux.kernel
Subject [PATCH 4/9] x86/microcode: Get rid of find_cpio_data()'s dummy offset arg
Date 2016-06-06 17:20 +0200
Message-ID <rH4tQ-6DT-37@gated-at.bofh.it> (permalink)
References <rH4tP-6DT-9@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: Borislav Petkov <bp@suse.de>

The microcode loader doesn't use it and now that that arg has been made
optional in find_cpio_data(), get rid of it here.

No functionality change.

Signed-off-by: Borislav Petkov <bp@suse.de>
---
 arch/x86/kernel/cpu/microcode/amd.c   | 3 +--
 arch/x86/kernel/cpu/microcode/intel.c | 3 +--
 2 files changed, 2 insertions(+), 4 deletions(-)

diff --git a/arch/x86/kernel/cpu/microcode/amd.c b/arch/x86/kernel/cpu/microcode/amd.c
index 11dd1cc8e444..b1d1e345f5f5 100644
--- a/arch/x86/kernel/cpu/microcode/amd.c
+++ b/arch/x86/kernel/cpu/microcode/amd.c
@@ -64,7 +64,6 @@ static struct cpio_data ucode_cpio;
 static struct cpio_data __init find_ucode_in_initrd(void)
 {
 #ifdef CONFIG_BLK_DEV_INITRD
-	long offset = 0;
 	char *path;
 	void *start;
 	size_t size;
@@ -92,7 +91,7 @@ static struct cpio_data __init find_ucode_in_initrd(void)
 	size    = boot_params.hdr.ramdisk_size;
 #endif /* !CONFIG_X86_32 */
 
-	return find_cpio_data(path, start, size, &offset);
+	return find_cpio_data(path, start, size, NULL);
 #else
 	return (struct cpio_data){ NULL, 0, "" };
 #endif
diff --git a/arch/x86/kernel/cpu/microcode/intel.c b/arch/x86/kernel/cpu/microcode/intel.c
index 5835d5b0db81..2ad40b73c8df 100644
--- a/arch/x86/kernel/cpu/microcode/intel.c
+++ b/arch/x86/kernel/cpu/microcode/intel.c
@@ -685,7 +685,6 @@ static __init enum ucode_state
 __scan_microcode_initrd(struct cpio_data *cd, struct ucode_blobs *blbp)
 {
 #ifdef CONFIG_BLK_DEV_INITRD
-	long offset = 0;
 	static __initdata char ucode_name[] = "kernel/x86/microcode/GenuineIntel.bin";
 	char *p = IS_ENABLED(CONFIG_X86_32) ? (char *)__pa_nodebug(ucode_name)
 						    : ucode_name;
@@ -716,7 +715,7 @@ __scan_microcode_initrd(struct cpio_data *cd, struct ucode_blobs *blbp)
 	}
 # endif
 
-	*cd = find_cpio_data(p, (void *)start, size, &offset);
+	*cd = find_cpio_data(p, (void *)start, size, NULL);
 	if (cd->data) {
 		blbp->start = start;
 		blbp->valid = true;
-- 
2.7.3

Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 0/9] x86/microcode: Fixes for builtin vs initrd loading; cleanups Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
  [PATCH 7/9] x86/microcode/intel: Unexport save_mc_for_early() Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
    [tip:x86/microcode] x86/microcode/intel: Unexport  save_mc_for_early() tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-06-08 12:00 +0200
  [PATCH 1/9] x86/microcode: Fix loading precedence Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
    [tip:x86/microcode] x86/microcode: Fix loading precedence tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-06-08 12:00 +0200
  [PATCH 6/9] x86/microcode/intel: Rename load_microcode_early() to find_microcode_patch() Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
    [tip:x86/microcode] x86/microcode/intel: Rename  load_microcode_early() to find_microcode_patch() tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-06-08 12:00 +0200
  [PATCH 8/9] x86/microcode/AMD: Make amd_ucode_patch static Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
    [tip:x86/microcode] x86/microcode/AMD: Make amd_ucode_patch[]  static tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-06-08 12:00 +0200
  [PATCH 9/9] Documentation/microcode: Document some aspects for more clarity Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
    [tip:x86/microcode] Documentation/microcode: Document some aspects  for more clarity tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-06-08 12:00 +0200
  [PATCH 4/9] x86/microcode: Get rid of find_cpio_data()'s dummy offset arg Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
    [tip:x86/microcode] x86/microcode: Get rid of find_cpio_data()'s  dummy offset arg tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-06-08 12:00 +0200
  [PATCH 3/9] lib/cpio: Make find_cpio_data()'s offset arg optional Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
    [tip:x86/microcode] lib/cpio: Make find_cpio_data()'s offset arg  optional tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-06-08 12:00 +0200

csiph-web