Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1415217
| From | Borislav Petkov <bp@alien8.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 3/9] lib/cpio: Make find_cpio_data()'s offset arg optional |
| Date | 2016-06-06 17:20 +0200 |
| Message-ID | <rH4tQ-6DT-41@gated-at.bofh.it> (permalink) |
| References | <rH4tP-6DT-9@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
From: Borislav Petkov <bp@suse.de>
Some callers don't use it so make it optional.
Signed-off-by: Borislav Petkov <bp@suse.de>
---
lib/earlycpio.c | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/lib/earlycpio.c b/lib/earlycpio.c
index 3eb3e4722b8e..db283ba4d2c1 100644
--- a/lib/earlycpio.c
+++ b/lib/earlycpio.c
@@ -125,7 +125,10 @@ struct cpio_data find_cpio_data(const char *path, void *data,
if ((ch[C_MODE] & 0170000) == 0100000 &&
ch[C_NAMESIZE] >= mypathsize &&
!memcmp(p, path, mypathsize)) {
- *nextoff = (long)nptr - (long)data;
+
+ if (nextoff)
+ *nextoff = (long)nptr - (long)data;
+
if (ch[C_NAMESIZE] - mypathsize >= MAX_CPIO_FILE_NAME) {
pr_warn(
"File %s exceeding MAX_CPIO_FILE_NAME [%d]\n",
--
2.7.3
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 0/9] x86/microcode: Fixes for builtin vs initrd loading; cleanups Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
[PATCH 7/9] x86/microcode/intel: Unexport save_mc_for_early() Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
[tip:x86/microcode] x86/microcode/intel: Unexport save_mc_for_early() tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-06-08 12:00 +0200
[PATCH 1/9] x86/microcode: Fix loading precedence Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
[tip:x86/microcode] x86/microcode: Fix loading precedence tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-06-08 12:00 +0200
[PATCH 6/9] x86/microcode/intel: Rename load_microcode_early() to find_microcode_patch() Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
[tip:x86/microcode] x86/microcode/intel: Rename load_microcode_early() to find_microcode_patch() tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-06-08 12:00 +0200
[PATCH 8/9] x86/microcode/AMD: Make amd_ucode_patch static Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
[tip:x86/microcode] x86/microcode/AMD: Make amd_ucode_patch[] static tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-06-08 12:00 +0200
[PATCH 9/9] Documentation/microcode: Document some aspects for more clarity Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
[tip:x86/microcode] Documentation/microcode: Document some aspects for more clarity tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-06-08 12:00 +0200
[PATCH 4/9] x86/microcode: Get rid of find_cpio_data()'s dummy offset arg Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
[tip:x86/microcode] x86/microcode: Get rid of find_cpio_data()'s dummy offset arg tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-06-08 12:00 +0200
[PATCH 3/9] lib/cpio: Make find_cpio_data()'s offset arg optional Borislav Petkov <bp@alien8.de> - 2016-06-06 17:20 +0200
[tip:x86/microcode] lib/cpio: Make find_cpio_data()'s offset arg optional tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-06-08 12:00 +0200
csiph-web