Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1410579
| From | Gustavo Padovan <gustavo@padovan.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 17/18] staging/android: rename sync.h to sync_debug.h |
| Date | 2016-05-31 22:10 +0200 |
| Message-ID | <rEY9b-7d9-9@gated-at.bofh.it> (permalink) |
| References | <rEXZw-6Uz-27@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
From: Gustavo Padovan <gustavo.padovan@collabora.co.uk>
This header file only contains information for debugging and SW_SYNC, so
rename it to sync_debug.h instead of having a more generic name.
Signed-off-by: Gustavo Padovan <gustavo.padovan@collabora.co.uk>
---
drivers/staging/android/sw_sync.c | 2 +-
drivers/staging/android/sync_debug.c | 2 +-
drivers/staging/android/{sync.h => sync_debug.h} | 0
drivers/staging/android/trace/sync.h | 2 +-
4 files changed, 3 insertions(+), 3 deletions(-)
rename drivers/staging/android/{sync.h => sync_debug.h} (100%)
diff --git a/drivers/staging/android/sw_sync.c b/drivers/staging/android/sw_sync.c
index ae56ece..115c917 100644
--- a/drivers/staging/android/sw_sync.c
+++ b/drivers/staging/android/sw_sync.c
@@ -20,7 +20,7 @@
#include <linux/slab.h>
#include <linux/sync_file.h>
-#include "sync.h"
+#include "sync_debug.h"
#define CREATE_TRACE_POINTS
#include "trace/sync.h"
diff --git a/drivers/staging/android/sync_debug.c b/drivers/staging/android/sync_debug.c
index b2697a1..b760226 100644
--- a/drivers/staging/android/sync_debug.c
+++ b/drivers/staging/android/sync_debug.c
@@ -15,7 +15,7 @@
*/
#include <linux/debugfs.h>
-#include "sync.h"
+#include "sync_debug.h"
#ifdef CONFIG_DEBUG_FS
diff --git a/drivers/staging/android/sync.h b/drivers/staging/android/sync_debug.h
similarity index 100%
rename from drivers/staging/android/sync.h
rename to drivers/staging/android/sync_debug.h
diff --git a/drivers/staging/android/trace/sync.h b/drivers/staging/android/trace/sync.h
index d7f6457f..6b5ce96 100644
--- a/drivers/staging/android/trace/sync.h
+++ b/drivers/staging/android/trace/sync.h
@@ -5,7 +5,7 @@
#if !defined(_TRACE_SYNC_H) || defined(TRACE_HEADER_MULTI_READ)
#define _TRACE_SYNC_H
-#include "../sync.h"
+#include "../sync_debug.h"
#include <linux/tracepoint.h>
TRACE_EVENT(sync_timeline,
--
2.5.5
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/18] staging/android: clean up SW_SYNC Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:00 +0200
[PATCH 08/18] staging/android: remove size arg of sync_timeline_create() Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 16/18] staging/android: remove drv_name from sync_timeline Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 04/18] staging/android: remove sw_sync_timeline and sw_sync_pt Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 17/18] staging/android: rename sync.h to sync_debug.h Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 05/18] staging/android: remove sw_sync.[ch] files Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 13/18] staging/android: make sw_ioctl info internal to sw_sync.c Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 10/18] staging/android: move sw_sync related code to sw_sync.c Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 12/18] staging/android: make sync_timeline internal to sw_sync Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 07/18] staging/android: remove unnecessary check for fence Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 09/18] staging/android: bring struct sync_pt back Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 14/18] staging/android: remove 'destroyed' member from struct sync_timeline Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 18/18] staging/android: add DEBUG_FS dependence on Kconfig Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 02/18] staging/android: remove .{fence,timeline}_value_str() from timeline_ops Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 01/18] staging/android: store last signaled value on sync timeline Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 11/18] staging/android: clean up #includes in the sync framework Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 15/18] staging/android: remove sync_timeline_destroy() Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 03/18] staging/android: remove struct sync_timeline_ops Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 06/18] staging/android: rename android_fence to timeline_fence Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
Re: [PATCH 00/18] staging/android: clean up SW_SYNC Gustavo Padovan <gustavo@padovan.org> - 2016-06-08 21:10 +0200
Re: [PATCH 00/18] staging/android: clean up SW_SYNC Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2016-06-09 07:50 +0200
Re: [PATCH 00/18] staging/android: clean up SW_SYNC Daniel Vetter <daniel@ffwll.ch> - 2016-06-09 10:30 +0200
Re: [PATCH 00/18] staging/android: clean up SW_SYNC Sumit Semwal <sumit.semwal@linaro.org> - 2016-06-09 16:00 +0200
csiph-web