Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1410576
| From | Gustavo Padovan <gustavo@padovan.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 08/18] staging/android: remove size arg of sync_timeline_create() |
| Date | 2016-05-31 22:10 +0200 |
| Message-ID | <rEY9b-7d9-1@gated-at.bofh.it> (permalink) |
| References | <rEXZw-6Uz-27@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
From: Gustavo Padovan <gustavo.padovan@collabora.co.uk>
After we removed sw_sync_timeline this arg has not been really used by
anyone, all its users pass the size of struct sync_timeline there.
So simplify this function but not requiring the size anymore.
Signed-off-by: Gustavo Padovan <gustavo.padovan@collabora.co.uk>
---
drivers/staging/android/sync.c | 7 ++-----
drivers/staging/android/sync.h | 7 ++-----
drivers/staging/android/sync_debug.c | 2 +-
3 files changed, 5 insertions(+), 11 deletions(-)
diff --git a/drivers/staging/android/sync.c b/drivers/staging/android/sync.c
index 442d808..c83a599 100644
--- a/drivers/staging/android/sync.c
+++ b/drivers/staging/android/sync.c
@@ -30,15 +30,12 @@
static const struct fence_ops timeline_fence_ops;
-struct sync_timeline *sync_timeline_create(int size, const char *drv_name,
+struct sync_timeline *sync_timeline_create(const char *drv_name,
const char *name)
{
struct sync_timeline *obj;
- if (size < sizeof(struct sync_timeline))
- return NULL;
-
- obj = kzalloc(size, GFP_KERNEL);
+ obj = kzalloc(sizeof(*obj), GFP_KERNEL);
if (!obj)
return NULL;
diff --git a/drivers/staging/android/sync.h b/drivers/staging/android/sync.h
index f003e97..f2fbf98 100644
--- a/drivers/staging/android/sync.h
+++ b/drivers/staging/android/sync.h
@@ -66,16 +66,13 @@ static inline struct sync_timeline *fence_parent(struct fence *fence)
/**
* sync_timeline_create() - creates a sync object
- * @size: size to allocate for this obj
* @drv_name: sync_timeline driver name
* @name: sync_timeline name
*
- * Creates a new sync_timeline. @size bytes will be allocated allowing
- * for implementation specific data to be kept after the generic
- * sync_timeline struct. Returns the sync_timeline object or NULL in
+ * Creates a new sync_timeline. Returns the sync_timeline object or NULL in
* case of error.
*/
-struct sync_timeline *sync_timeline_create(int size, const char *drv_name,
+struct sync_timeline *sync_timeline_create(const char *drv_name,
const char *name);
/**
diff --git a/drivers/staging/android/sync_debug.c b/drivers/staging/android/sync_debug.c
index 6282046..cb0f888 100644
--- a/drivers/staging/android/sync_debug.c
+++ b/drivers/staging/android/sync_debug.c
@@ -218,7 +218,7 @@ static int sw_sync_debugfs_open(struct inode *inode, struct file *file)
get_task_comm(task_comm, current);
- obj = sync_timeline_create(sizeof(*obj), "sw_sync", task_comm);
+ obj = sync_timeline_create("sw_sync", task_comm);
if (!obj)
return -ENOMEM;
--
2.5.5
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/18] staging/android: clean up SW_SYNC Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:00 +0200
[PATCH 08/18] staging/android: remove size arg of sync_timeline_create() Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 16/18] staging/android: remove drv_name from sync_timeline Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 04/18] staging/android: remove sw_sync_timeline and sw_sync_pt Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 17/18] staging/android: rename sync.h to sync_debug.h Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 05/18] staging/android: remove sw_sync.[ch] files Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 13/18] staging/android: make sw_ioctl info internal to sw_sync.c Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 10/18] staging/android: move sw_sync related code to sw_sync.c Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 12/18] staging/android: make sync_timeline internal to sw_sync Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 07/18] staging/android: remove unnecessary check for fence Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 09/18] staging/android: bring struct sync_pt back Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 14/18] staging/android: remove 'destroyed' member from struct sync_timeline Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 18/18] staging/android: add DEBUG_FS dependence on Kconfig Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 02/18] staging/android: remove .{fence,timeline}_value_str() from timeline_ops Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 01/18] staging/android: store last signaled value on sync timeline Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 11/18] staging/android: clean up #includes in the sync framework Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 15/18] staging/android: remove sync_timeline_destroy() Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 03/18] staging/android: remove struct sync_timeline_ops Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
[PATCH 06/18] staging/android: rename android_fence to timeline_fence Gustavo Padovan <gustavo@padovan.org> - 2016-05-31 22:10 +0200
Re: [PATCH 00/18] staging/android: clean up SW_SYNC Gustavo Padovan <gustavo@padovan.org> - 2016-06-08 21:10 +0200
Re: [PATCH 00/18] staging/android: clean up SW_SYNC Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2016-06-09 07:50 +0200
Re: [PATCH 00/18] staging/android: clean up SW_SYNC Daniel Vetter <daniel@ffwll.ch> - 2016-06-09 10:30 +0200
Re: [PATCH 00/18] staging/android: clean up SW_SYNC Sumit Semwal <sumit.semwal@linaro.org> - 2016-06-09 16:00 +0200
csiph-web