Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1332780
| From | Manoj Kumar <manoj@linux.vnet.ibm.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2 1/7] ibmvscsi: Correct values for several viosrp_crq_format enums |
| Date | 2016-02-12 15:30 +0100 |
| Message-ID | <r1mTo-8b8-9@gated-at.bofh.it> (permalink) |
| References | <r0OoF-1NH-3@gated-at.bofh.it> <r0OoG-1NH-7@gated-at.bofh.it> |
| Organization | IBM |
Reviewed-by: Manoj Kumar <manoj@linux.vnet.ibm.com>
---
Manoj Kumar
On 2/10/2016 7:32 PM, Tyrel Datwyler wrote:
> The enum values for VIOSRP_LINUX_FORMAT and VIOSRP_INLINE_FORMAT are
> off by one. They are currently defined as 0x06 and 0x07 respetively.
> These values are defined in PAPR correctly as 0x05 and 0x06. This
> inconsistency has gone unnoticed as neither enum is currently used.
> The possible future support of PING messages between the VIOS and
> client adapter relies on VIOSRP_INLINE_FORMAT crq messages.
> Corrected these enum values to match PAPR definitions.
>
> Signed-off-by: Tyrel Datwyler <tyreld@linux.vnet.ibm.com>
> Reviewed-by: Johannes Thumshirn <jthumshirn@suse.de>
> ---
> drivers/scsi/ibmvscsi/viosrp.h | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/scsi/ibmvscsi/viosrp.h b/drivers/scsi/ibmvscsi/viosrp.h
> index 1162430..d1044e9 100644
> --- a/drivers/scsi/ibmvscsi/viosrp.h
> +++ b/drivers/scsi/ibmvscsi/viosrp.h
> @@ -56,8 +56,8 @@ enum viosrp_crq_formats {
> VIOSRP_MAD_FORMAT = 0x02,
> VIOSRP_OS400_FORMAT = 0x03,
> VIOSRP_AIX_FORMAT = 0x04,
> - VIOSRP_LINUX_FORMAT = 0x06,
> - VIOSRP_INLINE_FORMAT = 0x07
> + VIOSRP_LINUX_FORMAT = 0x05,
> + VIOSRP_INLINE_FORMAT = 0x06
> };
>
> enum viosrp_crq_status {
>
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v2 0/7] ibmvscsi code cleanup Tyrel Datwyler <tyreld@linux.vnet.ibm.com> - 2016-02-11 02:40 +0100
[PATCH v2 5/7] ibmvscsi: Remove unsupported host config MAD Tyrel Datwyler <tyreld@linux.vnet.ibm.com> - 2016-02-11 02:40 +0100
Re: [PATCH v2 5/7] ibmvscsi: Remove unsupported host config MAD Johannes Thumshirn <jthumshirn@suse.de> - 2016-02-11 10:00 +0100
[PATCH v2 1/7] ibmvscsi: Correct values for several viosrp_crq_format enums Tyrel Datwyler <tyreld@linux.vnet.ibm.com> - 2016-02-11 02:40 +0100
Re: [PATCH v2 1/7] ibmvscsi: Correct values for several viosrp_crq_format enums Manoj Kumar <manoj@linux.vnet.ibm.com> - 2016-02-12 15:30 +0100
[PATCH v2 3/7] ibmvscsi: Replace magic values in set_adpater_info() with defines Tyrel Datwyler <tyreld@linux.vnet.ibm.com> - 2016-02-11 02:40 +0100
Re: [PATCH v2 3/7] ibmvscsi: Replace magic values in set_adpater_info() with defines James Bottomley <James.Bottomley@HansenPartnership.com> - 2016-02-12 17:50 +0100
Re: [PATCH v2 3/7] ibmvscsi: Replace magic values in set_adpater_info() with defines Tyrel Datwyler <tyreld@linux.vnet.ibm.com> - 2016-02-12 18:00 +0100
Re: [PATCH v2 3/7] ibmvscsi: Replace magic values in set_adpater_info() with defines James Bottomley <James.Bottomley@HansenPartnership.com> - 2016-02-12 18:00 +0100
Re: [PATCH v2 3/7] ibmvscsi: Replace magic values in set_adpater_info() with defines "Martin K. Petersen" <martin.petersen@oracle.com> - 2016-02-12 18:00 +0100
Re: [PATCH v2 3/7] ibmvscsi: Replace magic values in set_adpater_info() with defines "Martin K. Petersen" <martin.petersen@oracle.com> - 2016-02-17 04:10 +0100
Re: [PATCH v2 3/7] ibmvscsi: Replace magic values in set_adpater_info() with defines Johannes Thumshirn <jthumshirn@suse.de> - 2016-02-17 09:10 +0100
Re: [PATCH v2 3/7] ibmvscsi: Replace magic values in set_adpater_info() with defines Manoj Kumar <manoj@linux.vnet.ibm.com> - 2016-02-12 23:10 +0100
[PATCH v2 4/7] ibmvscsi: Use of_root to access OF device tree root node Tyrel Datwyler <tyreld@linux.vnet.ibm.com> - 2016-02-11 02:40 +0100
[PATCH v2 2/7] ibmvscsi: Add and use enums for valid CRQ header values Tyrel Datwyler <tyreld@linux.vnet.ibm.com> - 2016-02-11 02:40 +0100
Re: [PATCH v2 2/7] ibmvscsi: Add and use enums for valid CRQ header values Johannes Thumshirn <jthumshirn@suse.de> - 2016-02-11 10:00 +0100
Re: [PATCH v2 2/7] ibmvscsi: Add and use enums for valid CRQ header values Manoj Kumar <manoj@linux.vnet.ibm.com> - 2016-02-12 15:30 +0100
[PATCH v2 7/7] ibmvscsi: use H_CLOSED instead of magic number Tyrel Datwyler <tyreld@linux.vnet.ibm.com> - 2016-02-11 02:40 +0100
Re: [PATCH v2 7/7] ibmvscsi: use H_CLOSED instead of magic number Johannes Thumshirn <jthumshirn@suse.de> - 2016-02-11 10:00 +0100
Re: [PATCH v2 0/7] ibmvscsi code cleanup "Martin K. Petersen" <martin.petersen@oracle.com> - 2016-02-12 18:00 +0100
csiph-web