Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1270075
| From | Michal Hocko <mhocko@kernel.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 2/7] mm/hugetlb: is_file_hugepages can be boolean |
| Date | 2015-11-16 13:50 +0100 |
| Message-ID | <qvrom-7n2-11@gated-at.bofh.it> (permalink) |
| References | <qvlVD-3Sn-3@gated-at.bofh.it> <qvlVD-3Sn-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Mon 16-11-15 14:51:21, Yaowei Bai wrote:
> This patch makes is_file_hugepages return bool to improve
> readability due to this particular function only using either
> one or zero as its return value.
>
> This patch also removed the if condition to make is_file_hugepages
> return directly.
>
> No functional change.
>
> Signed-off-by: Yaowei Bai <baiyaowei@cmss.chinamobile.com>
I think this could be squashed into the previous patch.
Acked-by: Michal Hocko <mhocko@suse.com>
> ---
> include/linux/hugetlb.h | 10 ++++------
> 1 file changed, 4 insertions(+), 6 deletions(-)
>
> diff --git a/include/linux/hugetlb.h b/include/linux/hugetlb.h
> index 685c262..204c7f5 100644
> --- a/include/linux/hugetlb.h
> +++ b/include/linux/hugetlb.h
> @@ -265,20 +265,18 @@ struct file *hugetlb_file_setup(const char *name, size_t size, vm_flags_t acct,
> struct user_struct **user, int creat_flags,
> int page_size_log);
>
> -static inline int is_file_hugepages(struct file *file)
> +static inline bool is_file_hugepages(struct file *file)
> {
> if (file->f_op == &hugetlbfs_file_operations)
> - return 1;
> - if (is_file_shm_hugepages(file))
> - return 1;
> + return true;
>
> - return 0;
> + return is_file_shm_hugepages(file);
> }
>
>
> #else /* !CONFIG_HUGETLBFS */
>
> -#define is_file_hugepages(file) 0
> +#define is_file_hugepages(file) false
> static inline struct file *
> hugetlb_file_setup(const char *name, size_t size, vm_flags_t acctflag,
> struct user_struct **user, int creat_flags,
> --
> 1.9.1
>
>
--
Michal Hocko
SUSE Labs
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 2/7] mm/hugetlb: is_file_hugepages can be boolean Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-16 08:00 +0100 Re: [PATCH 2/7] mm/hugetlb: is_file_hugepages can be boolean Michal Hocko <mhocko@kernel.org> - 2015-11-16 13:50 +0100
csiph-web