Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1245814
| From | Frederic Weisbecker <fweisbec@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v3 2/2] sched: consider missed ticks when updating global cpu load |
| Date | 2015-10-13 17:00 +0200 |
| Message-ID | <qj9dw-1jL-29@gated-at.bofh.it> (permalink) |
| References | (2 earlier) <qfb4d-8hp-3@gated-at.bofh.it> <qfLr4-1dr-1@gated-at.bofh.it> <qg9a2-1Gp-5@gated-at.bofh.it> <qiPou-64e-15@gated-at.bofh.it> <qj1SG-7Dx-15@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, Oct 13, 2015 at 09:04:36AM +0200, Peter Zijlstra wrote: > On Mon, Oct 12, 2015 at 07:45:35PM +0200, Frederic Weisbecker wrote: > > > I think it will take more than a single patch to rework all of > > > update_process_times(). And we should also ask Thomas for his opinion, > > > but I think we want: > > > > > > - make update_process_times() take a nr_ticks argument > > > - fixup everything below it > > > > > > - fix tick_nohz_handler to not ignore the hrtimer_forward() > > > return value and pass it into > > > tick_sched_handle()/update_process_times(). > > > > > > (assuming this is the right oneshot tick part, tick-common > > > seems to be about periodic timers which aren't used much ?!) > > > > this_nohz_handler() is the low res nohz handler. tick_sched_handle() > > is the high res one (I should rename these). I think we should rather > > find out the pending updates from update_process_times() itself and pass > > it to scheduler_tick() which is the one interested in it. > > tick_nohz_handler() calls tick_sched_handler() ?! Confused I was. So tick_nohz_handler() is the low-res handler and tick_sched_timer() is the high-res (they still need rename I think). Both end up calling tick_sched_handle(). > > And tick_nohz_handler() actually computes the number of ticks -- which > we then happily ignore. > > Why compute it again a few functions down? Ah, you mean we could get the return value of hrtimer_foward()? Both callers use hrtimer_forward() and I think it's fine to call it before tick_sched_handle(). That sounds good! -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Re: [PATCH v3 2/2] sched: consider missed ticks when updating global cpu load Frederic Weisbecker <fweisbec@gmail.com> - 2015-10-12 19:50 +0200
Re: [PATCH v3 2/2] sched: consider missed ticks when updating global cpu load Peter Zijlstra <peterz@infradead.org> - 2015-10-13 09:10 +0200
Re: [PATCH v3 2/2] sched: consider missed ticks when updating global cpu load Byungchul Park <byungchul.park@lge.com> - 2015-10-13 10:40 +0200
Re: [PATCH v3 2/2] sched: consider missed ticks when updating global cpu load Frederic Weisbecker <fweisbec@gmail.com> - 2015-10-13 17:00 +0200
Re: [PATCH v3 2/2] sched: consider missed ticks when updating global cpu load Frederic Weisbecker <fweisbec@gmail.com> - 2015-10-13 17:00 +0200
Re: [PATCH v3 2/2] sched: consider missed ticks when updating global cpu load Peter Zijlstra <peterz@infradead.org> - 2015-10-13 17:00 +0200
csiph-web