Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1235178
| From | Steven Rostedt <rostedt@goodmis.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [RFC][PATCH 02/11] sched: Create preempt_count invariant |
| Date | 2015-09-29 16:50 +0200 |
| Message-ID | <qe4oa-ZN-33@gated-at.bofh.it> (permalink) |
| References | <qdZHQ-2IS-3@gated-at.bofh.it> <qdZHS-2IS-41@gated-at.bofh.it> <qe2FJ-6Wy-19@gated-at.bofh.it> <qe2Pn-7mR-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, 29 Sep 2015 15:02:01 +0200
Peter Zijlstra <peterz@infradead.org> wrote:
> On Tue, Sep 29, 2015 at 02:55:13PM +0200, Frederic Weisbecker wrote:
> > On Tue, Sep 29, 2015 at 11:28:27AM +0200, Peter Zijlstra wrote:
> > > #define init_task_preempt_count(p) do { \
> > > - task_thread_info(p)->preempt_count = PREEMPT_DISABLED; \
> > > + task_thread_info(p)->preempt_count = 2*PREEMPT_DISABLED; \
> >
> > Since it's not quite obvious why we use this magic value without looking
> > at schedule_tail() details, maybe add a little comment? (Just "/* see schedule_tail() */").
>
> Right, I fixed that in 12/11 v2. I'll change that around a bit.
I'll wait for v2 because this confused me too.
-- Steve
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[RFC][PATCH 02/11] sched: Create preempt_count invariant Peter Zijlstra <peterz@infradead.org> - 2015-09-29 11:50 +0200
[tip:sched/core] sched/core: Create preempt_count invariant tip-bot for Peter Zijlstra <tipbot@zytor.com> - 2015-09-29 12:40 +0200
Re: [RFC][PATCH 02/11] sched: Create preempt_count invariant Frederic Weisbecker <fweisbec@gmail.com> - 2015-09-29 15:00 +0200
Re: [RFC][PATCH 02/11] sched: Create preempt_count invariant Peter Zijlstra <peterz@infradead.org> - 2015-09-29 15:10 +0200
Re: [RFC][PATCH 02/11] sched: Create preempt_count invariant Steven Rostedt <rostedt@goodmis.org> - 2015-09-29 16:50 +0200
Re: [RFC][PATCH 02/11] sched: Create preempt_count invariant Thomas Gleixner <tglx@linutronix.de> - 2015-09-29 15:20 +0200
Re: [RFC][PATCH 02/11] sched: Create preempt_count invariant Peter Zijlstra <peterz@infradead.org> - 2015-09-29 16:20 +0200
csiph-web