Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1235147
| From | Peter Zijlstra <peterz@infradead.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [RFC][PATCH 02/11] sched: Create preempt_count invariant |
| Date | 2015-09-29 16:20 +0200 |
| Message-ID | <qe3V9-rR-23@gated-at.bofh.it> (permalink) |
| References | <qdZHQ-2IS-3@gated-at.bofh.it> <qdZHS-2IS-41@gated-at.bofh.it> <qe2Z4-7xW-7@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, Sep 29, 2015 at 03:11:56PM +0200, Thomas Gleixner wrote: > On Tue, 29 Sep 2015, Peter Zijlstra wrote: > > + /* > > + * Still have preempt_count() == 2, from: > > + * > > + * schedule() > > + * preempt_disable(); // 1 > > + * __schedule() > > + * raw_spin_lock_irq(&rq->lock) // 2 > > + */ > > + rq = finish_task_switch(prev); /* drops rq->lock, preempt_count() == 1 */ > > balance_callback(rq); > > - preempt_enable(); > > + preempt_enable(); /* preempt_count() == 0 */ > > Bah. I so hate tail comments. What's wrong with > > + /* preempt_count() ==> 0 */ > preempt_enable(); > > Hmm? I find the tail comments more readable in this case; clearly I don't share your hatred :-). But I can change them if you insist. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[RFC][PATCH 02/11] sched: Create preempt_count invariant Peter Zijlstra <peterz@infradead.org> - 2015-09-29 11:50 +0200
[tip:sched/core] sched/core: Create preempt_count invariant tip-bot for Peter Zijlstra <tipbot@zytor.com> - 2015-09-29 12:40 +0200
Re: [RFC][PATCH 02/11] sched: Create preempt_count invariant Frederic Weisbecker <fweisbec@gmail.com> - 2015-09-29 15:00 +0200
Re: [RFC][PATCH 02/11] sched: Create preempt_count invariant Peter Zijlstra <peterz@infradead.org> - 2015-09-29 15:10 +0200
Re: [RFC][PATCH 02/11] sched: Create preempt_count invariant Steven Rostedt <rostedt@goodmis.org> - 2015-09-29 16:50 +0200
Re: [RFC][PATCH 02/11] sched: Create preempt_count invariant Thomas Gleixner <tglx@linutronix.de> - 2015-09-29 15:20 +0200
Re: [RFC][PATCH 02/11] sched: Create preempt_count invariant Peter Zijlstra <peterz@infradead.org> - 2015-09-29 16:20 +0200
csiph-web