Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1227807
| From | LABBE Corentin <clabbe.montjoie@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 4/7] lib: introduce sg_nents_for_len2 |
| Date | 2015-09-18 14:30 +0200 |
| Message-ID | <qa2XE-2wy-9@gated-at.bofh.it> (permalink) |
| References | <q7a5k-2Ey-9@gated-at.bofh.it> <q7a5k-2Ey-19@gated-at.bofh.it> <qa2uC-1IY-11@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Fri, Sep 18, 2015 at 07:53:00PM +0800, Herbert Xu wrote: > On Thu, Sep 10, 2015 at 03:21:39PM +0200, LABBE Corentin wrote: > > Some driver use a modified version of sg_nents_for_len with an > > additional parameter bool *chained for knowing if the scatterlist is > > chained or not. > > > > So, for removing duplicate code, add sg_nents_for_len2 in > > lib/scatterlist.c > > This name is rather awkward. Perhaps sg_nents_len_chained? Perfect, thanks I will send the modified patch series with this function name soon. Regards -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
crypto: Remove duplicate code of SG helpers functions LABBE Corentin <clabbe.montjoie@gmail.com> - 2015-09-10 15:30 +0200
[PATCH 7/7] crypto: caam replace __sg_count with sg_nents_for_len2 LABBE Corentin <clabbe.montjoie@gmail.com> - 2015-09-10 15:30 +0200
[PATCH 2/7] crypto: amcc replace get_sg_count by sg_nents_for_len LABBE Corentin <clabbe.montjoie@gmail.com> - 2015-09-10 15:30 +0200
[PATCH 4/7] lib: introduce sg_nents_for_len2 LABBE Corentin <clabbe.montjoie@gmail.com> - 2015-09-10 15:30 +0200
Re: [PATCH 4/7] lib: introduce sg_nents_for_len2 Herbert Xu <herbert@gondor.apana.org.au> - 2015-09-18 14:00 +0200
Re: [PATCH 4/7] lib: introduce sg_nents_for_len2 Herbert Xu <herbert@gondor.apana.org.au> - 2015-09-18 14:30 +0200
Re: [PATCH 4/7] lib: introduce sg_nents_for_len2 Herbert Xu <herbert@gondor.apana.org.au> - 2015-09-18 14:50 +0200
Re: [PATCH 4/7] lib: introduce sg_nents_for_len2 LABBE Corentin <clabbe.montjoie@gmail.com> - 2015-09-18 14:50 +0200
Re: [PATCH 4/7] lib: introduce sg_nents_for_len2 LABBE Corentin <clabbe.montjoie@gmail.com> - 2015-09-18 14:30 +0200
[PATCH 1/7] crypto: bfin: replace sg_count by sg_nents LABBE Corentin <clabbe.montjoie@gmail.com> - 2015-09-10 15:30 +0200
[PATCH 5/7] crypto: talitos replace sg_count with sg_nents_for_len2 LABBE Corentin <clabbe.montjoie@gmail.com> - 2015-09-10 15:30 +0200
csiph-web