Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1222190
| From | LABBE Corentin <clabbe.montjoie@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | crypto: Remove duplicate code of SG helpers functions |
| Date | 2015-09-10 15:30 +0200 |
| Message-ID | <q7a5k-2Ey-9@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
Hello This patch series try to remove some duplicate code of some SG helpers functions. The first three patch replace custom functions by already in-tree helper functions. The fourth add a new functions "sg_nents_for_len2" who is the same as sg_nents_for_len with an additionnal arguments. Note that I do not like the name, but I do not find any good name. The last three patch use sg_nents_for_len2 for removing custom functions. I send those patch as RFC since I do not own any of those hardware to test. Regards -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
crypto: Remove duplicate code of SG helpers functions LABBE Corentin <clabbe.montjoie@gmail.com> - 2015-09-10 15:30 +0200
[PATCH 7/7] crypto: caam replace __sg_count with sg_nents_for_len2 LABBE Corentin <clabbe.montjoie@gmail.com> - 2015-09-10 15:30 +0200
[PATCH 2/7] crypto: amcc replace get_sg_count by sg_nents_for_len LABBE Corentin <clabbe.montjoie@gmail.com> - 2015-09-10 15:30 +0200
[PATCH 4/7] lib: introduce sg_nents_for_len2 LABBE Corentin <clabbe.montjoie@gmail.com> - 2015-09-10 15:30 +0200
Re: [PATCH 4/7] lib: introduce sg_nents_for_len2 Herbert Xu <herbert@gondor.apana.org.au> - 2015-09-18 14:00 +0200
Re: [PATCH 4/7] lib: introduce sg_nents_for_len2 Herbert Xu <herbert@gondor.apana.org.au> - 2015-09-18 14:30 +0200
Re: [PATCH 4/7] lib: introduce sg_nents_for_len2 Herbert Xu <herbert@gondor.apana.org.au> - 2015-09-18 14:50 +0200
Re: [PATCH 4/7] lib: introduce sg_nents_for_len2 LABBE Corentin <clabbe.montjoie@gmail.com> - 2015-09-18 14:50 +0200
Re: [PATCH 4/7] lib: introduce sg_nents_for_len2 LABBE Corentin <clabbe.montjoie@gmail.com> - 2015-09-18 14:30 +0200
[PATCH 1/7] crypto: bfin: replace sg_count by sg_nents LABBE Corentin <clabbe.montjoie@gmail.com> - 2015-09-10 15:30 +0200
[PATCH 5/7] crypto: talitos replace sg_count with sg_nents_for_len2 LABBE Corentin <clabbe.montjoie@gmail.com> - 2015-09-10 15:30 +0200
csiph-web