Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1325439

[PATCH v3 02/11] staging/android: rename sync_pt_info to sync_fence_info

From Gustavo Padovan <gustavo@padovan.org>
Newsgroups linux.kernel
Subject [PATCH v3 02/11] staging/android: rename sync_pt_info to sync_fence_info
Date 2016-02-03 14:30 +0100
Message-ID <qY5Fr-2vi-81@gated-at.bofh.it> (permalink)
References <qY5Fo-2vi-9@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: Gustavo Padovan <gustavo.padovan@collabora.co.uk>

As struct sync_pt doesn't exist anymore it is a good idea remove any
reference to it in the sync_framework. sync_pts were replaced directly by
fences and here we rename it to sync_fence_info to let the fence namespace
clean.

v2: rename fence_info to sync_fence_info (Maarten)

Signed-off-by: Gustavo Padovan <gustavo.padovan@collabora.co.uk>
---
 drivers/staging/android/sync.c      | 10 +++++-----
 drivers/staging/android/uapi/sync.h | 12 ++++++------
 2 files changed, 11 insertions(+), 11 deletions(-)

diff --git a/drivers/staging/android/sync.c b/drivers/staging/android/sync.c
index 381209a..f6ffb10 100644
--- a/drivers/staging/android/sync.c
+++ b/drivers/staging/android/sync.c
@@ -490,15 +490,15 @@ err_put_fd:
 	return err;
 }
 
-static int sync_fill_pt_info(struct fence *fence, void *data, int size)
+static int sync_fill_fence_info(struct fence *fence, void *data, int size)
 {
-	struct sync_pt_info *info = data;
+	struct sync_fence_info *info = data;
 	int ret;
 
-	if (size < sizeof(struct sync_pt_info))
+	if (size < sizeof(*info))
 		return -ENOMEM;
 
-	info->len = sizeof(struct sync_pt_info);
+	info->len = sizeof(*info);
 
 	if (fence->ops->fill_driver_data) {
 		ret = fence->ops->fill_driver_data(fence, info->driver_data,
@@ -553,7 +553,7 @@ static long sync_file_ioctl_fence_info(struct sync_file *sync_file,
 	for (i = 0; i < sync_file->num_fences; ++i) {
 		struct fence *fence = sync_file->cbs[i].fence;
 
-		ret = sync_fill_pt_info(fence, (u8 *)data + len, size - len);
+		ret = sync_fill_fence_info(fence, (u8 *)data + len, size - len);
 
 		if (ret < 0)
 			goto out;
diff --git a/drivers/staging/android/uapi/sync.h b/drivers/staging/android/uapi/sync.h
index 6c88c80..9a0c3cd 100644
--- a/drivers/staging/android/uapi/sync.h
+++ b/drivers/staging/android/uapi/sync.h
@@ -27,15 +27,15 @@ struct sync_merge_data {
 };
 
 /**
- * struct sync_pt_info - detailed sync_pt information
- * @len:		length of sync_pt_info including any driver_data
+ * struct sync_fence_info - detailed fence information
+ * @len:		length of sync_fence_info including any driver_data
  * @obj_name:		name of parent sync_timeline
  * @driver_name:	name of driver implementing the parent
- * @status:		status of the sync_pt 0:active 1:signaled <0:error
+ * @status:		status of the fence 0:active 1:signaled <0:error
  * @timestamp_ns:	timestamp of status change in nanoseconds
  * @driver_data:	any driver dependent data
  */
-struct sync_pt_info {
+struct sync_fence_info {
 	__u32	len;
 	char	obj_name[32];
 	char	driver_name[32];
@@ -52,14 +52,14 @@ struct sync_pt_info {
  *		userspace including pt_info.
  * @name:	name of fence
  * @status:	status of fence. 1: signaled 0:active <0:error
- * @pt_info:	a sync_pt_info struct for every sync_pt in the fence
+ * @sync_fence_info: array of sync_fence_info for every fence in the sync_file
  */
 struct sync_file_info_data {
 	__u32	len;
 	char	name[32];
 	__s32	status;
 
-	__u8	pt_info[0];
+	__u8	sync_fence_info[0];
 };
 
 #define SYNC_IOC_MAGIC		'>'
-- 
2.5.0

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v3 00/11] android sync framework: clean up IOCTLs and ABI  Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
  [PATCH v3 03/11] staging/android: rename sync_file_info_data to sync_file_info Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
  [PATCH v3 01/11] staging/android: remove SYNC_WAIT ioctl Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
  [PATCH v3 05/11] staging/android: remove len field from struct sync_fence_info Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
  [PATCH v3 09/11] staging/android: rename SYNC_IOC_FENCE_INFO Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
  [PATCH v3 08/11] staging/android: make info->len return only size of sync_fence_info array Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
  [PATCH v3 07/11] staging/android: add num_fences field to struct sync_file_info Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
  [PATCH v3 10/11] staging/android: add flags member to sync ioctl structs Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
  [PATCH v3 11/11] staging/android: remove redundant comments on sync_merge_data Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
  [PATCH v3 02/11] staging/android: rename sync_pt_info to sync_fence_info Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
  [PATCH v3 04/11] staging/android: remove driver_data from struct sync_fence_info Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
  [PATCH v3 06/11] staging/android: turn fence_info into a __u64 pointer Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:40 +0100
    Re: [PATCH v3 06/11] staging/android: turn fence_info into a __u64  pointer Maarten Lankhorst <maarten.lankhorst@linux.intel.com> - 2016-02-03 15:40 +0100
      Re: [PATCH v3 06/11] staging/android: turn fence_info into a __u64  pointer Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 21:20 +0100
        Re: [PATCH v3 06/11] staging/android: turn fence_info into a __u64  pointer Maarten Lankhorst <maarten.lankhorst@linux.intel.com> - 2016-02-04 11:00 +0100
          Re: [PATCH v3 06/11] staging/android: turn fence_info into a __u64  pointer Gustavo Padovan <gustavo.padovan@collabora.co.uk> - 2016-02-04 14:10 +0100
            Re: [PATCH v3 06/11] staging/android: turn fence_info into a __u64  pointer Maarten Lankhorst <maarten.lankhorst@linux.intel.com> - 2016-02-04 14:30 +0100
      Re: [PATCH v3 06/11] staging/android: turn fence_info into a __u64  pointer Daniel Vetter <daniel@ffwll.ch> - 2016-02-08 10:10 +0100

csiph-web