Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1325411
| From | Gustavo Padovan <gustavo@padovan.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH v3 00/11] android sync framework: clean up IOCTLs and ABI |
| Date | 2016-02-03 14:30 +0100 |
| Message-ID | <qY5Fo-2vi-9@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
From: Gustavo Padovan <gustavo.padovan@collabora.co.uk>
Hi,
This patch series clean up IOCTLs and abi of sync framework and it is a follow
up on the clean up series I've sent on Jan 21:
http://thread.gmane.org/gmane.comp.video.dri.devel/145509
The main changes here are:
* remove of SYNC_WAIT ioctl, poll() should be used instead.
* rename some structs and macros to better reflect the new internal names.
* clean up and improve ABI on SYNC_IOC_FILE_INFO
* add flags filed to all ABI structs
* make sync_file_info->len return only the size of the array of fence_infos
v2:
- Check flags passed to the kernel (Maarten)
- Rework len to report only the size of fence_infos array (Emil)
- Fix fence_info type. Use __u64 pointer type (Emil, Maarten)
v3:
- Rename fence_info to sync_fence_info (Maarten)
- Fix check for info.name (Maarten)
- Update commit description of patch 06 (Emil, Maarten)
Please review! Thanks.
Gustavo Padovan (11):
staging/android: remove SYNC_WAIT ioctl
staging/android: rename sync_pt_info to sync_fence_info
staging/android: rename sync_file_info_data to sync_file_info
staging/android: remove driver_data from struct sync_fence_info
staging/android: remove len field from struct sync_fence_info
staging/android: turn fence_info into a __u64 pointer
staging/android: add num_fences field to struct sync_file_info
staging/android: make info->len return only size of sync_fence_info
array
staging/android: rename SYNC_IOC_FENCE_INFO
staging/android: add flags member to sync ioctl structs
staging/android: remove redundant comments on sync_merge_data
drivers/staging/android/sw_sync.c | 14 ----
drivers/staging/android/sync.c | 129 +++++++++--------------------------
drivers/staging/android/sync.h | 20 ------
drivers/staging/android/trace/sync.h | 44 ------------
drivers/staging/android/uapi/sync.h | 50 ++++++--------
5 files changed, 56 insertions(+), 201 deletions(-)
--
2.5.0
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH v3 00/11] android sync framework: clean up IOCTLs and ABI Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
[PATCH v3 03/11] staging/android: rename sync_file_info_data to sync_file_info Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
[PATCH v3 01/11] staging/android: remove SYNC_WAIT ioctl Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
[PATCH v3 05/11] staging/android: remove len field from struct sync_fence_info Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
[PATCH v3 09/11] staging/android: rename SYNC_IOC_FENCE_INFO Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
[PATCH v3 08/11] staging/android: make info->len return only size of sync_fence_info array Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
[PATCH v3 07/11] staging/android: add num_fences field to struct sync_file_info Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
[PATCH v3 10/11] staging/android: add flags member to sync ioctl structs Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
[PATCH v3 11/11] staging/android: remove redundant comments on sync_merge_data Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
[PATCH v3 02/11] staging/android: rename sync_pt_info to sync_fence_info Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
[PATCH v3 04/11] staging/android: remove driver_data from struct sync_fence_info Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:30 +0100
[PATCH v3 06/11] staging/android: turn fence_info into a __u64 pointer Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 14:40 +0100
Re: [PATCH v3 06/11] staging/android: turn fence_info into a __u64 pointer Maarten Lankhorst <maarten.lankhorst@linux.intel.com> - 2016-02-03 15:40 +0100
Re: [PATCH v3 06/11] staging/android: turn fence_info into a __u64 pointer Gustavo Padovan <gustavo@padovan.org> - 2016-02-03 21:20 +0100
Re: [PATCH v3 06/11] staging/android: turn fence_info into a __u64 pointer Maarten Lankhorst <maarten.lankhorst@linux.intel.com> - 2016-02-04 11:00 +0100
Re: [PATCH v3 06/11] staging/android: turn fence_info into a __u64 pointer Gustavo Padovan <gustavo.padovan@collabora.co.uk> - 2016-02-04 14:10 +0100
Re: [PATCH v3 06/11] staging/android: turn fence_info into a __u64 pointer Maarten Lankhorst <maarten.lankhorst@linux.intel.com> - 2016-02-04 14:30 +0100
Re: [PATCH v3 06/11] staging/android: turn fence_info into a __u64 pointer Daniel Vetter <daniel@ffwll.ch> - 2016-02-08 10:10 +0100
csiph-web