Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1305230
| From | Christoph Hellwig <hch@infradead.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 01/35] block/fs/drivers: remove rw argument from submit_bio |
| Date | 2016-01-09 14:40 +0100 |
| Message-ID | <qP1Um-6bb-1@gated-at.bofh.it> (permalink) |
| References | <qNGRY-860-9@gated-at.bofh.it> <qNHbk-8sH-17@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, Jan 05, 2016 at 02:53:04PM -0600, mchristi@redhat.com wrote:
> From: Mike Christie <mchristi@redhat.com>
>
> This has callers of submit_bio/submit_bio_wait set the bio->bi_rw
> instead of passing it in. This makes that use the same as
> generic_make_request and how we set the other bio fields.
>
> Signed-off-by: Mike Christie <mchristi@redhat.com>
> ---
> block/bio.c | 7 +++----
> block/blk-core.c | 11 ++++-------
> block/blk-flush.c | 3 ++-
> block/blk-lib.c | 9 ++++++---
> drivers/block/drbd/drbd_actlog.c | 2 +-
> drivers/block/drbd/drbd_bitmap.c | 4 ++--
> drivers/block/floppy.c | 3 ++-
> drivers/block/xen-blkback/blkback.c | 4 +++-
> drivers/block/xen-blkfront.c | 4 ++--
> drivers/md/bcache/debug.c | 6 ++++--
> drivers/md/bcache/journal.c | 2 +-
> drivers/md/bcache/super.c | 4 ++--
> drivers/md/dm-bufio.c | 3 ++-
> drivers/md/dm-io.c | 3 ++-
> drivers/md/dm-log-writes.c | 9 ++++++---
> drivers/md/dm-thin.c | 3 ++-
> drivers/md/md.c | 10 +++++++---
> drivers/md/raid1.c | 3 ++-
> drivers/md/raid10.c | 4 +++-
> drivers/md/raid5-cache.c | 7 ++++---
> drivers/target/target_core_iblock.c | 24 +++++++++++++-----------
> fs/btrfs/check-integrity.c | 18 ++++++++++--------
> fs/btrfs/check-integrity.h | 4 ++--
> fs/btrfs/disk-io.c | 3 ++-
> fs/btrfs/extent_io.c | 7 ++++---
> fs/btrfs/raid56.c | 16 +++++++++++-----
> fs/btrfs/scrub.c | 16 +++++++++++-----
> fs/btrfs/volumes.c | 14 +++++++-------
> fs/buffer.c | 3 ++-
> fs/direct-io.c | 3 ++-
> fs/ext4/crypto.c | 3 ++-
> fs/ext4/page-io.c | 3 ++-
> fs/ext4/readpage.c | 9 +++++----
> fs/f2fs/data.c | 13 ++++++++-----
> fs/f2fs/segment.c | 6 ++++--
> fs/gfs2/lops.c | 3 ++-
> fs/gfs2/meta_io.c | 3 ++-
> fs/gfs2/ops_fstype.c | 3 ++-
> fs/hfsplus/wrapper.c | 3 ++-
> fs/jfs/jfs_logmgr.c | 6 ++++--
> fs/jfs/jfs_metapage.c | 10 ++++++----
> fs/logfs/dev_bdev.c | 15 ++++++++++-----
> fs/mpage.c | 3 ++-
> fs/nfs/blocklayout/blocklayout.c | 22 ++++++++++++----------
> fs/nilfs2/segbuf.c | 3 ++-
> fs/ocfs2/cluster/heartbeat.c | 12 +++++++-----
> fs/xfs/xfs_aops.c | 3 ++-
> fs/xfs/xfs_buf.c | 4 ++--
> include/linux/bio.h | 2 +-
> include/linux/fs.h | 2 +-
> kernel/power/swap.c | 5 +++--
> mm/page_io.c | 10 ++++++----
> 52 files changed, 211 insertions(+), 141 deletions(-)
>
> diff --git a/block/bio.c b/block/bio.c
> index dbabd48..921112b 100644
> --- a/block/bio.c
> +++ b/block/bio.c
> @@ -859,21 +859,20 @@ static void submit_bio_wait_endio(struct bio *bio)
>
> /**
> * submit_bio_wait - submit a bio, and wait until it completes
> - * @rw: whether to %READ or %WRITE, or maybe to %READA (read ahead)
> * @bio: The &struct bio which describes the I/O
> *
> * Simple wrapper around submit_bio(). Returns 0 on success, or the error from
> * bio_endio() on failure.
> */
> -int submit_bio_wait(int rw, struct bio *bio)
> +int submit_bio_wait(struct bio *bio)
> {
> struct submit_bio_ret ret;
>
> - rw |= REQ_SYNC;
> init_completion(&ret.event);
> bio->bi_private = &ret;
> bio->bi_end_io = submit_bio_wait_endio;
> - submit_bio(rw, bio);
> + bio->bi_rw |= REQ_SYNC;
> + submit_bio(bio);
> wait_for_completion(&ret.event);
>
> return ret.error;
> diff --git a/block/blk-core.c b/block/blk-core.c
> index ab51685..9b887e3 100644
> --- a/block/blk-core.c
> +++ b/block/blk-core.c
> @@ -2092,7 +2092,6 @@ EXPORT_SYMBOL(generic_make_request);
>
> /**
> * submit_bio - submit a bio to the block device layer for I/O
> - * @rw: whether to %READ or %WRITE, or maybe to %READA (read ahead)
> * @bio: The &struct bio which describes the I/O
> *
> * submit_bio() is very similar in purpose to generic_make_request(), and
> @@ -2100,10 +2099,8 @@ EXPORT_SYMBOL(generic_make_request);
> * interfaces; @bio must be presetup and ready for I/O.
> *
> */
> -blk_qc_t submit_bio(int rw, struct bio *bio)
> +blk_qc_t submit_bio(struct bio *bio)
> {
> - bio->bi_rw |= rw;
> -
> /*
> * If it's a regular read/write or a barrier with data attached,
> * go through the normal accounting stuff before submission.
> @@ -2111,12 +2108,12 @@ blk_qc_t submit_bio(int rw, struct bio *bio)
> if (bio_has_data(bio)) {
> unsigned int count;
>
> - if (unlikely(rw & REQ_WRITE_SAME))
> + if (unlikely(bio->bi_rw & REQ_WRITE_SAME))
> count = bdev_logical_block_size(bio->bi_bdev) >> 9;
> else
> count = bio_sectors(bio);
>
> - if (rw & WRITE) {
> + if (bio->bi_rw & WRITE) {
> count_vm_events(PGPGOUT, count);
> } else {
> task_io_account_read(bio->bi_iter.bi_size);
> @@ -2127,7 +2124,7 @@ blk_qc_t submit_bio(int rw, struct bio *bio)
> char b[BDEVNAME_SIZE];
> printk(KERN_DEBUG "%s(%d): %s block %Lu on %s (%u sectors)\n",
> current->comm, task_pid_nr(current),
> - (rw & WRITE) ? "WRITE" : "READ",
> + (bio->bi_rw & WRITE) ? "WRITE" : "READ",
> (unsigned long long)bio->bi_iter.bi_sector,
> bdevname(bio->bi_bdev, b),
> count);
> diff --git a/block/blk-flush.c b/block/blk-flush.c
> index 9c423e5..e092e13 100644
> --- a/block/blk-flush.c
> +++ b/block/blk-flush.c
> @@ -484,8 +484,9 @@ int blkdev_issue_flush(struct block_device *bdev, gfp_t gfp_mask,
>
> bio = bio_alloc(gfp_mask, 0);
> bio->bi_bdev = bdev;
> + bio->bi_rw |= WRITE_FLUSH;
Shouldn't the |= be a = here and in many other places?
Otherwise this loks fine to me.
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/35 v2] separate operations from flags in the bio/request structs mchristi@redhat.com - 2016-01-05 22:00 +0100
[PATCH 35/35] block, drivers, fs: rename REQ_FLUSH to REQ_PREFLUSH mchristi@redhat.com - 2016-01-05 22:00 +0100
Re: [PATCH 35/35] block, drivers, fs: rename REQ_FLUSH to REQ_PREFLUSH kbuild test robot <lkp@intel.com> - 2016-01-06 01:00 +0100
[PATCH 21/35] bcache: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields mchristi@redhat.com - 2016-01-05 22:10 +0100
Re: [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields "Martin K. Petersen" <martin.petersen@oracle.com> - 2016-01-07 00:20 +0100
Re: [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields Christoph Hellwig <hch@infradead.org> - 2016-01-09 14:40 +0100
Re: [dm-devel] [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields Mike Christie <michaelc@cs.wisc.edu> - 2016-01-10 02:00 +0100
Re: [dm-devel] [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields Mike Christie <michaelc@cs.wisc.edu> - 2016-01-10 02:30 +0100
Re: [dm-devel] [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields Christoph Hellwig <hch@infradead.org> - 2016-01-10 08:20 +0100
Re: [dm-devel] [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields Christoph Hellwig <hch@infradead.org> - 2016-01-10 08:20 +0100
[PATCH 22/35] drbd: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 13/35] xfs: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
Re: [PATCH 13/35] xfs: set bi_op to REQ_OP Dave Chinner <david@fromorbit.com> - 2016-01-07 04:20 +0100
[PATCH 14/35] hfsplus: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 15/35] mpage: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 28/35] blktrace: get op from req->op/bio->bi_op mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 18/35] pm: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 12/35] gfs2: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 19/35] dm: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 24/35] xen: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 10/35] btrfs: don't pass rq_flag_bits if there is a bio mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 27/35] drivers: set request op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 23/35] md/raid: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 09/35] btrfs: update __btrfs_map_block for bi_op transition mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 16/35] nilfs: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 25/35] target: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
Re: [PATCH 25/35] target: set bi_op to REQ_OP "Nicholas A. Bellinger" <nab@linux-iscsi.org> - 2016-01-06 20:10 +0100
[PATCH 17/35] ocfs2: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 07/35] btrfs: have submit_one_bio users setup bio bi_op mchristi@redhat.com - 2016-01-05 22:20 +0100
[PATCH 06/35] direct-io: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:20 +0100
[PATCH 08/35] btrfs: set bi_op tp REQ_OP mchristi@redhat.com - 2016-01-05 22:20 +0100
[PATCH 05/35] fs: have ll_rw_block users pass in op and flags separately mchristi@redhat.com - 2016-01-05 22:20 +0100
Re: [PATCH 05/35] fs: have ll_rw_block users pass in op and flags separately kbuild test robot <lkp@intel.com> - 2016-01-06 00:30 +0100
[PATCH 04/35] fs: have submit_bh users pass in op and flags separately mchristi@redhat.com - 2016-01-05 22:20 +0100
Re: [PATCH 00/35 v2] separate operations from flags in the bio/request structs "Martin K. Petersen" <martin.petersen@oracle.com> - 2016-01-07 02:50 +0100
Re: [PATCH 00/35 v2] separate operations from flags in the bio/request structs Dave Chinner <david@fromorbit.com> - 2016-01-07 04:20 +0100
Re: [PATCH 00/35 v2] separate operations from flags in the bio/request structs Christoph Hellwig <hch@infradead.org> - 2016-01-08 14:40 +0100
Re: [PATCH 00/35 v2] separate operations from flags in the bio/request structs Mike Christie <michaelc@cs.wisc.edu> - 2016-01-08 22:00 +0100
Re: [PATCH 00/35 v2] separate operations from flags in the bio/request structs Mike Snitzer <snitzer@redhat.com> - 2016-01-09 00:10 +0100
Re: [PATCH 01/35] block/fs/drivers: remove rw argument from submit_bio Christoph Hellwig <hch@infradead.org> - 2016-01-09 14:40 +0100
Re: [PATCH 01/35] block/fs/drivers: remove rw argument from submit_bio Mike Christie <michaelc@cs.wisc.edu> - 2016-01-10 01:50 +0100
csiph-web