Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1302279
| From | kbuild test robot <lkp@intel.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 35/35] block, drivers, fs: rename REQ_FLUSH to REQ_PREFLUSH |
| Date | 2016-01-06 01:00 +0100 |
| Message-ID | <qNJGa-1vi-5@gated-at.bofh.it> (permalink) |
| References | <qNGRZ-860-45@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
[Multipart message — attachments visible in raw view] - view raw
Hi Mike,
[auto build test ERROR on next-20160105]
[cannot apply to dm/for-next v4.4-rc8 v4.4-rc7 v4.4-rc6 v4.4-rc8]
[if your patch is applied to the wrong git tree, please drop us a note to help improving the system]
url: https://github.com/0day-ci/linux/commits/mchristi-redhat-com/separate-operations-from-flags-in-the-bio-request-structs/20160106-052858
config: um-x86_64_defconfig (attached as .config)
reproduce:
# save the attached .config to linux build tree
make ARCH=um SUBARCH=x86_64
All errors (new ones prefixed by >>):
arch/um/drivers/ubd_kern.c: In function 'ubd_add':
arch/um/drivers/ubd_kern.c:869:43: error: macro "blk_queue_flush" passed 2 arguments, but takes just 1
blk_queue_flush(ubd_dev->queue, REQ_FLUSH);
^
arch/um/drivers/ubd_kern.c:869:2: error: 'blk_queue_flush' undeclared (first use in this function)
blk_queue_flush(ubd_dev->queue, REQ_FLUSH);
^
arch/um/drivers/ubd_kern.c:869:2: note: each undeclared identifier is reported only once for each function it appears in
arch/um/drivers/ubd_kern.c: In function 'do_ubd_request':
>> arch/um/drivers/ubd_kern.c:1293:24: error: 'REQ_FLUSH' undeclared (first use in this function)
if (req->cmd_flags & REQ_FLUSH) {
^
vim +/REQ_FLUSH +1293 arch/um/drivers/ubd_kern.c
a0044bdf Jeff Dike 2007-05-06 1287 dev->start_sg = 0;
a0044bdf Jeff Dike 2007-05-06 1288 dev->end_sg = blk_rq_map_sg(q, req, dev->sg);
a0044bdf Jeff Dike 2007-05-06 1289 }
a0044bdf Jeff Dike 2007-05-06 1290
a0044bdf Jeff Dike 2007-05-06 1291 req = dev->request;
805f11a0 Richard Weinberger 2013-08-18 1292
805f11a0 Richard Weinberger 2013-08-18 @1293 if (req->cmd_flags & REQ_FLUSH) {
805f11a0 Richard Weinberger 2013-08-18 1294 io_req = kmalloc(sizeof(struct io_thread_req),
805f11a0 Richard Weinberger 2013-08-18 1295 GFP_ATOMIC);
805f11a0 Richard Weinberger 2013-08-18 1296 if (io_req == NULL) {
:::::: The code at line 1293 was first introduced by commit
:::::: 805f11a0d515658106bfbfadceff0eb30bd90ad2 um: ubd: Add REQ_FLUSH suppport
:::::: TO: Richard Weinberger <richard@nod.at>
:::::: CC: Richard Weinberger <richard@nod.at>
---
0-DAY kernel test infrastructure Open Source Technology Center
https://lists.01.org/pipermail/kbuild-all Intel Corporation
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/35 v2] separate operations from flags in the bio/request structs mchristi@redhat.com - 2016-01-05 22:00 +0100
[PATCH 35/35] block, drivers, fs: rename REQ_FLUSH to REQ_PREFLUSH mchristi@redhat.com - 2016-01-05 22:00 +0100
Re: [PATCH 35/35] block, drivers, fs: rename REQ_FLUSH to REQ_PREFLUSH kbuild test robot <lkp@intel.com> - 2016-01-06 01:00 +0100
[PATCH 21/35] bcache: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields mchristi@redhat.com - 2016-01-05 22:10 +0100
Re: [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields "Martin K. Petersen" <martin.petersen@oracle.com> - 2016-01-07 00:20 +0100
Re: [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields Christoph Hellwig <hch@infradead.org> - 2016-01-09 14:40 +0100
Re: [dm-devel] [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields Mike Christie <michaelc@cs.wisc.edu> - 2016-01-10 02:00 +0100
Re: [dm-devel] [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields Mike Christie <michaelc@cs.wisc.edu> - 2016-01-10 02:30 +0100
Re: [dm-devel] [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields Christoph Hellwig <hch@infradead.org> - 2016-01-10 08:20 +0100
Re: [dm-devel] [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields Christoph Hellwig <hch@infradead.org> - 2016-01-10 08:20 +0100
[PATCH 22/35] drbd: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 13/35] xfs: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
Re: [PATCH 13/35] xfs: set bi_op to REQ_OP Dave Chinner <david@fromorbit.com> - 2016-01-07 04:20 +0100
[PATCH 14/35] hfsplus: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 15/35] mpage: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 28/35] blktrace: get op from req->op/bio->bi_op mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 18/35] pm: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 12/35] gfs2: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 19/35] dm: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 24/35] xen: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 10/35] btrfs: don't pass rq_flag_bits if there is a bio mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 27/35] drivers: set request op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 23/35] md/raid: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 09/35] btrfs: update __btrfs_map_block for bi_op transition mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 16/35] nilfs: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 25/35] target: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
Re: [PATCH 25/35] target: set bi_op to REQ_OP "Nicholas A. Bellinger" <nab@linux-iscsi.org> - 2016-01-06 20:10 +0100
[PATCH 17/35] ocfs2: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 07/35] btrfs: have submit_one_bio users setup bio bi_op mchristi@redhat.com - 2016-01-05 22:20 +0100
[PATCH 06/35] direct-io: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:20 +0100
[PATCH 08/35] btrfs: set bi_op tp REQ_OP mchristi@redhat.com - 2016-01-05 22:20 +0100
[PATCH 05/35] fs: have ll_rw_block users pass in op and flags separately mchristi@redhat.com - 2016-01-05 22:20 +0100
Re: [PATCH 05/35] fs: have ll_rw_block users pass in op and flags separately kbuild test robot <lkp@intel.com> - 2016-01-06 00:30 +0100
[PATCH 04/35] fs: have submit_bh users pass in op and flags separately mchristi@redhat.com - 2016-01-05 22:20 +0100
Re: [PATCH 00/35 v2] separate operations from flags in the bio/request structs "Martin K. Petersen" <martin.petersen@oracle.com> - 2016-01-07 02:50 +0100
Re: [PATCH 00/35 v2] separate operations from flags in the bio/request structs Dave Chinner <david@fromorbit.com> - 2016-01-07 04:20 +0100
Re: [PATCH 00/35 v2] separate operations from flags in the bio/request structs Christoph Hellwig <hch@infradead.org> - 2016-01-08 14:40 +0100
Re: [PATCH 00/35 v2] separate operations from flags in the bio/request structs Mike Christie <michaelc@cs.wisc.edu> - 2016-01-08 22:00 +0100
Re: [PATCH 00/35 v2] separate operations from flags in the bio/request structs Mike Snitzer <snitzer@redhat.com> - 2016-01-09 00:10 +0100
Re: [PATCH 01/35] block/fs/drivers: remove rw argument from submit_bio Christoph Hellwig <hch@infradead.org> - 2016-01-09 14:40 +0100
Re: [PATCH 01/35] block/fs/drivers: remove rw argument from submit_bio Mike Christie <michaelc@cs.wisc.edu> - 2016-01-10 01:50 +0100
csiph-web