Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1302174
| From | mchristi@redhat.com |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 00/35 v2] separate operations from flags in the bio/request structs |
| Date | 2016-01-05 22:00 +0100 |
| Message-ID | <qNGRY-860-9@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
The following patches begin to cleanup the request->cmd_flags and bio->bi_rw mess. We currently use cmd_flags to specify the operation, attributes and state of the request. For bi_rw we use it for similar info and also the priority but then also have another bi_flags field for state. At some point, we abused them so much we just made cmd_flags 64 bits, so we could add more. The following patches seperate the operation (read, write discard, flush, etc) from cmd_flags/bi_rw. This patchset was made against linux-next from today Jan 5 2016. (git tag next-20160105). v2. 1. Dropped arguments from submit_bio, and had callers setup bio. 2. Add REQ_OP_FLUSH for request_fn users and renamed REQ_FLUSH to REQ_PREFLUSH for make_request_fn users. 3. Dropped bio/rq_data_dir functions, and added a op_is_write function instead. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH 00/35 v2] separate operations from flags in the bio/request structs mchristi@redhat.com - 2016-01-05 22:00 +0100
[PATCH 35/35] block, drivers, fs: rename REQ_FLUSH to REQ_PREFLUSH mchristi@redhat.com - 2016-01-05 22:00 +0100
Re: [PATCH 35/35] block, drivers, fs: rename REQ_FLUSH to REQ_PREFLUSH kbuild test robot <lkp@intel.com> - 2016-01-06 01:00 +0100
[PATCH 21/35] bcache: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields mchristi@redhat.com - 2016-01-05 22:10 +0100
Re: [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields "Martin K. Petersen" <martin.petersen@oracle.com> - 2016-01-07 00:20 +0100
Re: [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields Christoph Hellwig <hch@infradead.org> - 2016-01-09 14:40 +0100
Re: [dm-devel] [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields Mike Christie <michaelc@cs.wisc.edu> - 2016-01-10 02:00 +0100
Re: [dm-devel] [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields Mike Christie <michaelc@cs.wisc.edu> - 2016-01-10 02:30 +0100
Re: [dm-devel] [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields Christoph Hellwig <hch@infradead.org> - 2016-01-10 08:20 +0100
Re: [dm-devel] [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields Christoph Hellwig <hch@infradead.org> - 2016-01-10 08:20 +0100
[PATCH 22/35] drbd: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 13/35] xfs: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
Re: [PATCH 13/35] xfs: set bi_op to REQ_OP Dave Chinner <david@fromorbit.com> - 2016-01-07 04:20 +0100
[PATCH 14/35] hfsplus: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 15/35] mpage: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 28/35] blktrace: get op from req->op/bio->bi_op mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 18/35] pm: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 12/35] gfs2: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 19/35] dm: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 24/35] xen: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 10/35] btrfs: don't pass rq_flag_bits if there is a bio mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 27/35] drivers: set request op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 23/35] md/raid: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 09/35] btrfs: update __btrfs_map_block for bi_op transition mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 16/35] nilfs: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 25/35] target: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
Re: [PATCH 25/35] target: set bi_op to REQ_OP "Nicholas A. Bellinger" <nab@linux-iscsi.org> - 2016-01-06 20:10 +0100
[PATCH 17/35] ocfs2: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:10 +0100
[PATCH 07/35] btrfs: have submit_one_bio users setup bio bi_op mchristi@redhat.com - 2016-01-05 22:20 +0100
[PATCH 06/35] direct-io: set bi_op to REQ_OP mchristi@redhat.com - 2016-01-05 22:20 +0100
[PATCH 08/35] btrfs: set bi_op tp REQ_OP mchristi@redhat.com - 2016-01-05 22:20 +0100
[PATCH 05/35] fs: have ll_rw_block users pass in op and flags separately mchristi@redhat.com - 2016-01-05 22:20 +0100
Re: [PATCH 05/35] fs: have ll_rw_block users pass in op and flags separately kbuild test robot <lkp@intel.com> - 2016-01-06 00:30 +0100
[PATCH 04/35] fs: have submit_bh users pass in op and flags separately mchristi@redhat.com - 2016-01-05 22:20 +0100
Re: [PATCH 00/35 v2] separate operations from flags in the bio/request structs "Martin K. Petersen" <martin.petersen@oracle.com> - 2016-01-07 02:50 +0100
Re: [PATCH 00/35 v2] separate operations from flags in the bio/request structs Dave Chinner <david@fromorbit.com> - 2016-01-07 04:20 +0100
Re: [PATCH 00/35 v2] separate operations from flags in the bio/request structs Christoph Hellwig <hch@infradead.org> - 2016-01-08 14:40 +0100
Re: [PATCH 00/35 v2] separate operations from flags in the bio/request structs Mike Christie <michaelc@cs.wisc.edu> - 2016-01-08 22:00 +0100
Re: [PATCH 00/35 v2] separate operations from flags in the bio/request structs Mike Snitzer <snitzer@redhat.com> - 2016-01-09 00:10 +0100
Re: [PATCH 01/35] block/fs/drivers: remove rw argument from submit_bio Christoph Hellwig <hch@infradead.org> - 2016-01-09 14:40 +0100
Re: [PATCH 01/35] block/fs/drivers: remove rw argument from submit_bio Mike Christie <michaelc@cs.wisc.edu> - 2016-01-10 01:50 +0100
csiph-web