Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1301652
| From | Eric Dumazet <eric.dumazet@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] net: filter: make JITs zero A for SKF_AD_ALU_XOR_X |
| Date | 2016-01-05 17:10 +0100 |
| Message-ID | <qNClk-5bm-9@gated-at.bofh.it> (permalink) |
| References | <qNBIC-4FF-29@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, 2016-01-05 at 16:23 +0100, Rabin Vincent wrote:
> The SKF_AD_ALU_XOR_X ancillary is not like the other ancillary data
> instructions since it XORs A with X while all the others replace A with
> some loaded value. All the BPF JITs fail to clear A if this is used as
> the first instruction in a filter.
Is x86_64 part of this 'All' subset ? ;)
> This was found using american fuzzy
> lop.
>
> Add a helper to determine if A needs to be cleared given the first
> instruction in a filter, and use this in the JITs. Except for ARM, the
> rest have only been compile-tested.
>
> Fixes: 3480593131e0 ("net: filter: get rid of BPF_S_* enum")
> Signed-off-by: Rabin Vincent <rabin@rab.in>
> ---
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] net: filter: make JITs zero A for SKF_AD_ALU_XOR_X Rabin Vincent <rabin@rab.in> - 2016-01-05 16:30 +0100
Re: [PATCH] net: filter: make JITs zero A for SKF_AD_ALU_XOR_X Eric Dumazet <eric.dumazet@gmail.com> - 2016-01-05 17:10 +0100
Re: [PATCH] net: filter: make JITs zero A for SKF_AD_ALU_XOR_X Rabin Vincent <rabin@rab.in> - 2016-01-05 17:10 +0100
Re: [PATCH] net: filter: make JITs zero A for SKF_AD_ALU_XOR_X Daniel Borkmann <daniel@iogearbox.net> - 2016-01-05 17:40 +0100
Re: [PATCH] net: filter: make JITs zero A for SKF_AD_ALU_XOR_X Daniel Borkmann <daniel@iogearbox.net> - 2016-01-05 17:40 +0100
Re: [PATCH] net: filter: make JITs zero A for SKF_AD_ALU_XOR_X Alexei Starovoitov <alexei.starovoitov@gmail.com> - 2016-01-05 18:50 +0100
Re: [PATCH] net: filter: make JITs zero A for SKF_AD_ALU_XOR_X David Miller <davem@davemloft.net> - 2016-01-06 06:50 +0100
csiph-web