Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1218586

Re: [alsa-devel] [PATCH 1/2] ASoC: qcom: change PTR_ERR argument

From Kenneth Westfield <kwestfie@codeaurora.org>
Newsgroups linux.kernel
Subject Re: [alsa-devel] [PATCH 1/2] ASoC: qcom: change PTR_ERR argument
Date 2015-09-03 23:40 +0200
Message-ID <q4KoG-7iO-9@gated-at.bofh.it> (permalink)
References <q3fmV-8oI-5@gated-at.bofh.it> <q3fmW-8oI-21@gated-at.bofh.it> <q3fZE-He-7@gated-at.bofh.it> <q3gVI-22C-7@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Sun, Aug 30, 2015 at 12:54:15PM -0700, Julia Lawall wrote:
> On Sun, 30 Aug 2015, walter harms wrote:
> > Am 30.08.2015 20:05, schrieb Julia Lawall:
> > >  		if (IS_ERR(drvdata->mi2s_bit_clk[dai_id])) {
> > >  			dev_err(&pdev->dev,
> > >  				"%s() error getting mi2s-bit-clk: %ld\n",
> > > -				__func__,
> PTR_ERR(drvdata->mi2s_bit_clk[i]));
> > > +				__func__,
> > > +				PTR_ERR(drvdata->mi2s_bit_clk[dai_id]));
> > >  			return PTR_ERR(drvdata->mi2s_bit_clk[dai_id]);
> > >  		}
> > >  	}
> > > 
> > 
> > just a note:
> > using a shorter name instead of drvdata->mi2s_bit_clk[dai_id] whould
> help to make the code
> > more readable (yes, the other code is alike). something like:
> > 
> > struct clk *tmp =  devm_clk_get(&pdev->dev,clk_name);
> 
> Where do you suggest to put this?
> 
> Maybe it would be reasonable to declare a variable struct clk *clk; at the
> 
> top of the function, and then use that as a temporary variable for all 
> three calls.
> 
> However, now I see that the first call, unlike the other two doesn't cause
> 
> a return from the function.
> 
>                 if (IS_ERR(drvdata->mi2s_osr_clk[dai_id])) {
>                         dev_warn(&pdev->dev,
>                                 "%s() error getting mi2s-osr-clk: %ld\n",
> 				__func__,
> 		                PTR_ERR(drvdata->mi2s_osr_clk[dai_id]));
>                 }
> 
> Is that intentional?

Yes, that was intentional as the presense of the OSR clock in the DT
node is optional.

-- 
Kenneth Westfield
Qualcomm Innovation Center, Inc.
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum, 
a Linux Foundation Collaborative Project
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 0/2] change PTR_ERR argument Julia Lawall <Julia.Lawall@lip6.fr> - 2015-08-30 20:20 +0200
  [PATCH 2/2] spi: spi-ep93xx: change PTR_ERR argument Julia Lawall <Julia.Lawall@lip6.fr> - 2015-08-30 20:20 +0200
    Re: [PATCH 2/2] spi: spi-ep93xx: change PTR_ERR argument walter harms <wharms@bfs.de> - 2015-08-30 20:40 +0200
      [PATCH 2/2 v2] spi: spi-ep93xx: fix PTR_ERR problem Julia Lawall <julia.lawall@lip6.fr> - 2015-08-30 22:20 +0200
  [PATCH 1/2] ASoC: qcom: change PTR_ERR argument Julia Lawall <Julia.Lawall@lip6.fr> - 2015-08-30 20:20 +0200
    Re: [PATCH 1/2] ASoC: qcom: change PTR_ERR argument walter harms <wharms@bfs.de> - 2015-08-30 21:00 +0200
      Re: [PATCH 1/2] ASoC: qcom: change PTR_ERR argument Julia Lawall <julia.lawall@lip6.fr> - 2015-08-30 22:00 +0200
        Re: [alsa-devel] [PATCH 1/2] ASoC: qcom: change PTR_ERR argument Kenneth Westfield <kwestfie@codeaurora.org> - 2015-09-03 23:40 +0200
      Re: [alsa-devel] [PATCH 1/2] ASoC: qcom: change PTR_ERR argument Kenneth Westfield <kwestfie@codeaurora.org> - 2015-09-03 23:40 +0200
    Re: [alsa-devel] [PATCH 1/2] ASoC: qcom: change PTR_ERR argument Kenneth Westfield <kwestfie@codeaurora.org> - 2015-09-03 23:20 +0200

csiph-web