Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1215956

Re: [PATCH 1/2] ASoC: qcom: change PTR_ERR argument

From walter harms <wharms@bfs.de>
Newsgroups linux.kernel
Subject Re: [PATCH 1/2] ASoC: qcom: change PTR_ERR argument
Date 2015-08-30 21:00 +0200
Message-ID <q3fZE-He-7@gated-at.bofh.it> (permalink)
References <q3fmV-8oI-5@gated-at.bofh.it> <q3fmW-8oI-21@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw



Am 30.08.2015 20:05, schrieb Julia Lawall:
> Apply PTR_ERR to the value that was recently assigned.
> 
> The semantic match that finds this problem is as follows:
> (http://coccinelle.lip6.fr/)
> 
> // <smpl>
> @@
> expression x,y;
> @@
> 
> if (IS_ERR(x) || ...) {
>   ... when any
>       when != IS_ERR(...)
> (
>    PTR_ERR(x)
> |
> *  PTR_ERR(y)
> )
>   ... when any
> }
> // </smpl>
> 
> Signed-off-by: Julia Lawall <Julia.Lawall@lip6.fr>
> 
> ---
>  sound/soc/qcom/lpass-cpu.c |    3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/sound/soc/qcom/lpass-cpu.c b/sound/soc/qcom/lpass-cpu.c
> index 23f3d59..94beb99 100644
> --- a/sound/soc/qcom/lpass-cpu.c
> +++ b/sound/soc/qcom/lpass-cpu.c
> @@ -438,7 +438,8 @@ int asoc_qcom_lpass_cpu_platform_probe(struct platform_device *pdev)
>  		if (IS_ERR(drvdata->mi2s_bit_clk[dai_id])) {
>  			dev_err(&pdev->dev,
>  				"%s() error getting mi2s-bit-clk: %ld\n",
> -				__func__, PTR_ERR(drvdata->mi2s_bit_clk[i]));
> +				__func__,
> +				PTR_ERR(drvdata->mi2s_bit_clk[dai_id]));
>  			return PTR_ERR(drvdata->mi2s_bit_clk[dai_id]);
>  		}
>  	}
> 

just a note:
using a shorter name instead of drvdata->mi2s_bit_clk[dai_id] whould help to make the code
more readable (yes, the other code is alike). something like:

struct clk *tmp =  devm_clk_get(&pdev->dev,clk_name);

if (IS_ERR(tmp)) {
	dev_err(&pdev->dev,"%s() error getting mi2s-bit-clk: %ld\n",__func__, PTR_ERR(tmp));
        return PTR_ERR(tmp);
}
drvdata->mi2s_bit_clk[dai_id]=tmp;


just one minor:
the dev_warn() just before says: " error getting mi2s-osr-clk" may be it should be "warnig ..."
That will make it more easy to rep for real error in a log.

re,
 wh

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 0/2] change PTR_ERR argument Julia Lawall <Julia.Lawall@lip6.fr> - 2015-08-30 20:20 +0200
  [PATCH 2/2] spi: spi-ep93xx: change PTR_ERR argument Julia Lawall <Julia.Lawall@lip6.fr> - 2015-08-30 20:20 +0200
    Re: [PATCH 2/2] spi: spi-ep93xx: change PTR_ERR argument walter harms <wharms@bfs.de> - 2015-08-30 20:40 +0200
      [PATCH 2/2 v2] spi: spi-ep93xx: fix PTR_ERR problem Julia Lawall <julia.lawall@lip6.fr> - 2015-08-30 22:20 +0200
  [PATCH 1/2] ASoC: qcom: change PTR_ERR argument Julia Lawall <Julia.Lawall@lip6.fr> - 2015-08-30 20:20 +0200
    Re: [PATCH 1/2] ASoC: qcom: change PTR_ERR argument walter harms <wharms@bfs.de> - 2015-08-30 21:00 +0200
      Re: [PATCH 1/2] ASoC: qcom: change PTR_ERR argument Julia Lawall <julia.lawall@lip6.fr> - 2015-08-30 22:00 +0200
        Re: [alsa-devel] [PATCH 1/2] ASoC: qcom: change PTR_ERR argument Kenneth Westfield <kwestfie@codeaurora.org> - 2015-09-03 23:40 +0200
      Re: [alsa-devel] [PATCH 1/2] ASoC: qcom: change PTR_ERR argument Kenneth Westfield <kwestfie@codeaurora.org> - 2015-09-03 23:40 +0200
    Re: [alsa-devel] [PATCH 1/2] ASoC: qcom: change PTR_ERR argument Kenneth Westfield <kwestfie@codeaurora.org> - 2015-09-03 23:20 +0200

csiph-web