Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1216495

[PATCH 06/15] x86, fpu: rename XFEATURES_NR_MAX

From Dave Hansen <dave@sr71.net>
Newsgroups linux.kernel
Subject [PATCH 06/15] x86, fpu: rename XFEATURES_NR_MAX
Date 2015-09-01 00:40 +0200
Message-ID <q3FU6-4sb-31@gated-at.bofh.it> (permalink)
References <q3FKq-4gF-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: Dave Hansen <dave.hansen@linux.intel.com>

This is a logcal followon to the last patch.  It makes the
XFEATURE_MAX naming consistent with the other enum values.
This is what Ingo suggested.

Signed-off-by: Dave Hansen <dave.hansen@linux.intel.com>
Cc: Ingo Molnar <mingo@redhat.com>
Cc: x86@kernel.org
Cc: Borislav Petkov <bp@alien8.de>
Cc: Fenghua Yu <fenghua.yu@intel.com>
Cc: Tim Chen <tim.c.chen@linux.intel.com>
Cc: linux-kernel@vger.kernel.org
---

 b/arch/x86/include/asm/fpu/types.h |    2 +-
 b/arch/x86/kernel/fpu/xstate.c     |    4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)

diff -puN arch/x86/include/asm/fpu/types.h~rename-XFEATURES_NR_MAX arch/x86/include/asm/fpu/types.h
--- a/arch/x86/include/asm/fpu/types.h~rename-XFEATURES_NR_MAX	2015-08-31 15:17:33.710851053 -0700
+++ b/arch/x86/include/asm/fpu/types.h	2015-08-31 15:17:33.714851236 -0700
@@ -109,7 +109,7 @@ enum xfeature {
 	XFEATURE_ZMM_Hi256,
 	XFEATURE_Hi16_ZMM,
 
-	XFEATURES_NR_MAX,
+	XFEATURE_MAX,
 };
 
 #define XFEATURE_MASK_FP		(1 << XFEATURE_FP)
diff -puN arch/x86/kernel/fpu/xstate.c~rename-XFEATURES_NR_MAX arch/x86/kernel/fpu/xstate.c
--- a/arch/x86/kernel/fpu/xstate.c~rename-XFEATURES_NR_MAX	2015-08-31 15:17:33.711851099 -0700
+++ b/arch/x86/kernel/fpu/xstate.c	2015-08-31 15:17:33.715851281 -0700
@@ -31,8 +31,8 @@ static const char *xfeature_names[] =
  */
 u64 xfeatures_mask __read_mostly;
 
-static unsigned int xstate_offsets[XFEATURES_NR_MAX] = { [ 0 ... XFEATURES_NR_MAX - 1] = -1};
-static unsigned int xstate_sizes[XFEATURES_NR_MAX]   = { [ 0 ... XFEATURES_NR_MAX - 1] = -1};
+static unsigned int xstate_offsets[XFEATURE_MAX] = { [ 0 ... XFEATURE_MAX - 1] = -1};
+static unsigned int xstate_sizes[XFEATURE_MAX]   = { [ 0 ... XFEATURE_MAX - 1] = -1};
 static unsigned int xstate_comp_offsets[sizeof(xfeatures_mask)*8];
 
 /* The number of supported xfeatures in xfeatures_mask: */
_
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 00/15] [v3] x86, fpu: XSAVE cleanups and sanity checks Dave Hansen <dave@sr71.net> - 2015-09-01 00:30 +0200
  [PATCH 10/15] x86, fpu: rework MPX 'xstate' types Dave Hansen <dave@sr71.net> - 2015-09-01 00:30 +0200
  [PATCH 15/15] x86, fpu: check CPU-provided sizes against struct declarations Dave Hansen <dave@sr71.net> - 2015-09-01 00:30 +0200
  [PATCH 02/15] x86, fpu: move XSAVE-disabling code to a helper Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200
  [PATCH 13/15] x86, fpu: correct and check XSAVE xstate size calculations Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200
  [PATCH 05/15] x86, fpu: XSAVE macro renames Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200
    Re: [PATCH 05/15] x86, fpu: XSAVE macro renames Dave Hansen <dave@sr71.net> - 2015-09-01 01:50 +0200
  [PATCH 11/15] x86, fpu: rework YMM definition Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200
  [PATCH 06/15] x86, fpu: rename XFEATURES_NR_MAX Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200
  [PATCH 04/15] x86, fpu: kill LWP support Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200
  [PATCH 09/15] x86, fpu: add helper xfeature_enabled() instead of test_bit() Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200
  [PATCH 07/15] x86, fpu: rework XSTATE_* macros to remove magic '2' Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200
  [PATCH 12/15] x86, fpu: add C structures for AVX-512 state components Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200
  [PATCH 03/15] x86, fpu: remove XSTATE_RESERVE Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200
  [PATCH 08/15] x86, fpu: remove xfeature_nr Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200

csiph-web