Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1216494

[PATCH 11/15] x86, fpu: rework YMM definition

From Dave Hansen <dave@sr71.net>
Newsgroups linux.kernel
Subject [PATCH 11/15] x86, fpu: rework YMM definition
Date 2015-09-01 00:40 +0200
Message-ID <q3FU6-4sb-23@gated-at.bofh.it> (permalink)
References <q3FKq-4gF-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: Dave Hansen <dave.hansen@linux.intel.com>

We are about to rework all of the "extended state" definitions.
This makes the 'ymm' naming consistent with the AVX-512 types
we will introduce later.

We also add a convenience type: "reg_128_bit" so that we do
not have to spell out our arithmetic.

Signed-off-by: Dave Hansen <dave.hansen@linux.intel.com>
Cc: Ingo Molnar <mingo@redhat.com>
Cc: x86@kernel.org
Cc: Borislav Petkov <bp@alien8.de>
Cc: Fenghua Yu <fenghua.yu@intel.com>
Cc: Tim Chen <tim.c.chen@linux.intel.com>
Cc: linux-kernel@vger.kernel.org
---

 b/arch/x86/include/asm/fpu/types.h |   16 +++++++++++-----
 1 file changed, 11 insertions(+), 5 deletions(-)

diff -puN arch/x86/include/asm/fpu/types.h~x86-fpu-rework-ymm-types arch/x86/include/asm/fpu/types.h
--- a/arch/x86/include/asm/fpu/types.h~x86-fpu-rework-ymm-types	2015-08-31 15:17:35.919952013 -0700
+++ b/arch/x86/include/asm/fpu/types.h	2015-08-31 15:17:35.922952150 -0700
@@ -128,17 +128,23 @@ enum xfeature {
 
 #define FIRST_EXTENDED_XFEATURE	XFEATURE_YMM
 
+struct reg_128_bit {
+	u8      regbytes[128/8];
+};
+
 /*
+ * State component 2:
+ *
  * There are 16x 256-bit AVX registers named YMM0-YMM15.
  * The low 128 bits are aliased to the 16 SSE registers (XMM0-XMM15)
- * and are stored in 'struct fxregs_state::xmm_space[]'.
+ * and are stored in 'struct fxregs_state::xmm_space[]' in the
+ * "legacy" area.
  *
- * The high 128 bits are stored here:
- *    16x 128 bits == 256 bytes.
+ * The high 128 bits are stored here.
  */
 struct ymmh_struct {
-	u8				ymmh_space[256];
-};
+	struct reg_128_bit              hi_ymm[16];
+} __packed;
 
 /* Intel MPX support: */
 
_
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 00/15] [v3] x86, fpu: XSAVE cleanups and sanity checks Dave Hansen <dave@sr71.net> - 2015-09-01 00:30 +0200
  [PATCH 10/15] x86, fpu: rework MPX 'xstate' types Dave Hansen <dave@sr71.net> - 2015-09-01 00:30 +0200
  [PATCH 15/15] x86, fpu: check CPU-provided sizes against struct declarations Dave Hansen <dave@sr71.net> - 2015-09-01 00:30 +0200
  [PATCH 02/15] x86, fpu: move XSAVE-disabling code to a helper Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200
  [PATCH 13/15] x86, fpu: correct and check XSAVE xstate size calculations Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200
  [PATCH 05/15] x86, fpu: XSAVE macro renames Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200
    Re: [PATCH 05/15] x86, fpu: XSAVE macro renames Dave Hansen <dave@sr71.net> - 2015-09-01 01:50 +0200
  [PATCH 11/15] x86, fpu: rework YMM definition Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200
  [PATCH 06/15] x86, fpu: rename XFEATURES_NR_MAX Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200
  [PATCH 04/15] x86, fpu: kill LWP support Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200
  [PATCH 09/15] x86, fpu: add helper xfeature_enabled() instead of test_bit() Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200
  [PATCH 07/15] x86, fpu: rework XSTATE_* macros to remove magic '2' Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200
  [PATCH 12/15] x86, fpu: add C structures for AVX-512 state components Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200
  [PATCH 03/15] x86, fpu: remove XSTATE_RESERVE Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200
  [PATCH 08/15] x86, fpu: remove xfeature_nr Dave Hansen <dave@sr71.net> - 2015-09-01 00:40 +0200

csiph-web