Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1211814

[PATCH 09/17] staging: sm750fb: ddk750_swi2c: staticize swI2C{SCL,SDA}

From Mike Rapoport <mike.rapoport@gmail.com>
Newsgroups linux.kernel
Subject [PATCH 09/17] staging: sm750fb: ddk750_swi2c: staticize swI2C{SCL,SDA}
Date 2015-08-24 07:30 +0200
Message-ID <q0Suv-6Fn-31@gated-at.bofh.it> (permalink)
References <q0Sut-6Fn-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Signed-off-by: Mike Rapoport <mike.rapoport@gmail.com>
---
 drivers/staging/sm750fb/ddk750_swi2c.c |  4 ++--
 drivers/staging/sm750fb/ddk750_swi2c.h | 21 ---------------------
 2 files changed, 2 insertions(+), 23 deletions(-)

diff --git a/drivers/staging/sm750fb/ddk750_swi2c.c b/drivers/staging/sm750fb/ddk750_swi2c.c
index e3f60eb..6a10ae3 100644
--- a/drivers/staging/sm750fb/ddk750_swi2c.c
+++ b/drivers/staging/sm750fb/ddk750_swi2c.c
@@ -119,7 +119,7 @@ static void swI2CWait(void)
  *      signal because the i2c will fail when other device try to drive the
  *      signal due to SM50x will drive the signal to always high.
  */
-void swI2CSCL(unsigned char value)
+static void swI2CSCL(unsigned char value)
 {
 	unsigned long ulGPIOData;
 	unsigned long ulGPIODirection;
@@ -153,7 +153,7 @@ void swI2CSCL(unsigned char value)
  *      signal because the i2c will fail when other device try to drive the
  *      signal due to SM50x will drive the signal to always high.
  */
-void swI2CSDA(unsigned char value)
+static void swI2CSDA(unsigned char value)
 {
 	unsigned long ulGPIOData;
 	unsigned long ulGPIODirection;
diff --git a/drivers/staging/sm750fb/ddk750_swi2c.h b/drivers/staging/sm750fb/ddk750_swi2c.h
index 37335dd..27a04f3a 100644
--- a/drivers/staging/sm750fb/ddk750_swi2c.h
+++ b/drivers/staging/sm750fb/ddk750_swi2c.h
@@ -68,25 +68,4 @@ long sm750_sw_i2c_write_reg(
 	unsigned char data
 );
 
-/*
- *  These two functions toggle the data on the SCL and SDA I2C lines.
- *  The use of these two functions is not recommended unless it is necessary.
- */
-
-/*
- *  This function set/reset the SCL GPIO pin
- *
- *  Parameters:
- *      value	- Bit value to set to the SCL or SDA (0 = low, 1 = high)
- */
-void swI2CSCL(unsigned char value);
-
-/*
- *  This function set/reset the SDA GPIO pin
- *
- *  Parameters:
- *      value	- Bit value to set to the SCL or SDA (0 = low, 1 = high)
- */
-void swI2CSDA(unsigned char value);
-
 #endif  /* _SWI2C_H_ */
-- 
2.1.0

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 00/17] staging: sm750fb: coding style fixes Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
  [PATCH 11/17] staging: sm750fb: ddk750_hw_i2c: rename busSpeedMode Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
  [PATCH 10/17] staging: sm750fb: ddk750_swi2c: rename CamelCase static functions Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
  [PATCH 07/17] staging: sm750fb: rename swI2CReadReg to sm750_sw_i2c_read_reg Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
  [PATCH 06/17] staging: sm750fb: rename swI2CInit to sm750_sw_i2c_init Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
  [PATCH 14/17] staging: sm750fb: ddk750_swi2c: rename CamelCase static variables Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
  [PATCH 17/17] staging: sm750fb: ddk750_*i2c: shorten lines to under 80 characters Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
  [PATCH 03/17] staging: sm750fb: rename hwI2CReadReg to sm750_hw_i2c_read_reg Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
  [PATCH 12/17] staging: sm750fb: hw_i2c_{read,write}: rename CamelCase variables Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
  [PATCH 01/17] staging: sm750fb: rename hwI2CInit to sm750_hw_i2c_init Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
    Re: [PATCH 01/17] staging: sm750fb: rename hwI2CInit to  sm750_hw_i2c_init Greg Kroah-Hartman <greg@kroah.com> - 2015-09-04 03:20 +0200
  [PATCH 04/17] staging: sm750fb: rename hwI2CWriteReg to sm750_hw_i2c_write_reg Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
  [PATCH 09/17] staging: sm750fb: ddk750_swi2c: staticize swI2C{SCL,SDA} Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
  [PATCH 13/17] staging: sm750fb: ddk750_hwi2c: reduce amount of CamelCase Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
  [PATCH 05/17] staging: sm750fb: ddk750_hwi2c: rename CamelCase static functions Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
    Re: [PATCH 05/17] staging: sm750fb: ddk750_hwi2c: rename CamelCase  static functions Greg Kroah-Hartman <greg@kroah.com> - 2015-09-04 03:20 +0200

csiph-web