Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1211811
| From | Mike Rapoport <mike.rapoport@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 12/17] staging: sm750fb: hw_i2c_{read,write}: rename CamelCase variables |
| Date | 2015-08-24 07:30 +0200 |
| Message-ID | <q0Suv-6Fn-27@gated-at.bofh.it> (permalink) |
| References | <q0Sut-6Fn-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Rename longCamelCase variables deviceAddress and registerIndex to
shorter addr and reg
Signed-off-by: Mike Rapoport <mike.rapoport@gmail.com>
---
drivers/staging/sm750fb/ddk750_hwi2c.c | 16 ++++++++--------
drivers/staging/sm750fb/ddk750_hwi2c.h | 4 ++--
2 files changed, 10 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/sm750fb/ddk750_hwi2c.c b/drivers/staging/sm750fb/ddk750_hwi2c.c
index c4c2dad..616c42f 100644
--- a/drivers/staging/sm750fb/ddk750_hwi2c.c
+++ b/drivers/staging/sm750fb/ddk750_hwi2c.c
@@ -220,14 +220,14 @@ static unsigned int sm750_hw_i2c_read_data(
* Register value
*/
unsigned char sm750_hw_i2c_read_reg(
- unsigned char deviceAddress,
- unsigned char registerIndex
+ unsigned char addr,
+ unsigned char reg
)
{
unsigned char value = (0xFF);
- if (sm750_hw_i2c_write_data(deviceAddress, 1, ®isterIndex) == 1)
- sm750_hw_i2c_read_data(deviceAddress, 1, &value);
+ if (sm750_hw_i2c_write_data(addr, 1, ®) == 1)
+ sm750_hw_i2c_read_data(addr, 1, &value);
return value;
}
@@ -250,16 +250,16 @@ unsigned char sm750_hw_i2c_read_reg(
* -1 - Fail
*/
int sm750_hw_i2c_write_reg(
- unsigned char deviceAddress,
- unsigned char registerIndex,
+ unsigned char addr,
+ unsigned char reg,
unsigned char data
)
{
unsigned char value[2];
- value[0] = registerIndex;
+ value[0] = reg;
value[1] = data;
- if (sm750_hw_i2c_write_data(deviceAddress, 2, value) == 2)
+ if (sm750_hw_i2c_write_data(addr, 2, value) == 2)
return 0;
return (-1);
diff --git a/drivers/staging/sm750fb/ddk750_hwi2c.h b/drivers/staging/sm750fb/ddk750_hwi2c.h
index 5872f9c..2827865 100644
--- a/drivers/staging/sm750fb/ddk750_hwi2c.h
+++ b/drivers/staging/sm750fb/ddk750_hwi2c.h
@@ -5,6 +5,6 @@
int sm750_hw_i2c_init(unsigned char bus_speed_mode);
void sm750_hw_i2c_close(void);
-unsigned char sm750_hw_i2c_read_reg(unsigned char deviceAddress, unsigned char registerIndex);
-int sm750_hw_i2c_write_reg(unsigned char deviceAddress, unsigned char registerIndex, unsigned char data);
+unsigned char sm750_hw_i2c_read_reg(unsigned char addr, unsigned char reg);
+int sm750_hw_i2c_write_reg(unsigned char addr, unsigned char reg, unsigned char data);
#endif
--
2.1.0
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/17] staging: sm750fb: coding style fixes Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
[PATCH 11/17] staging: sm750fb: ddk750_hw_i2c: rename busSpeedMode Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
[PATCH 10/17] staging: sm750fb: ddk750_swi2c: rename CamelCase static functions Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
[PATCH 07/17] staging: sm750fb: rename swI2CReadReg to sm750_sw_i2c_read_reg Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
[PATCH 06/17] staging: sm750fb: rename swI2CInit to sm750_sw_i2c_init Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
[PATCH 14/17] staging: sm750fb: ddk750_swi2c: rename CamelCase static variables Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
[PATCH 17/17] staging: sm750fb: ddk750_*i2c: shorten lines to under 80 characters Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
[PATCH 03/17] staging: sm750fb: rename hwI2CReadReg to sm750_hw_i2c_read_reg Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
[PATCH 12/17] staging: sm750fb: hw_i2c_{read,write}: rename CamelCase variables Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
[PATCH 01/17] staging: sm750fb: rename hwI2CInit to sm750_hw_i2c_init Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
Re: [PATCH 01/17] staging: sm750fb: rename hwI2CInit to sm750_hw_i2c_init Greg Kroah-Hartman <greg@kroah.com> - 2015-09-04 03:20 +0200
[PATCH 04/17] staging: sm750fb: rename hwI2CWriteReg to sm750_hw_i2c_write_reg Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
[PATCH 09/17] staging: sm750fb: ddk750_swi2c: staticize swI2C{SCL,SDA} Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
[PATCH 13/17] staging: sm750fb: ddk750_hwi2c: reduce amount of CamelCase Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
[PATCH 05/17] staging: sm750fb: ddk750_hwi2c: rename CamelCase static functions Mike Rapoport <mike.rapoport@gmail.com> - 2015-08-24 07:30 +0200
Re: [PATCH 05/17] staging: sm750fb: ddk750_hwi2c: rename CamelCase static functions Greg Kroah-Hartman <greg@kroah.com> - 2015-09-04 03:20 +0200
csiph-web