Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > comp.lang.java.programmer > #27581
| Date | 2014-02-24 09:06 +0000 |
|---|---|
| From | lipska the kat <lipskathekat@example.com> |
| Organization | Trollbusters 3 |
| Newsgroups | comp.lang.java.programmer |
| Subject | Re: java code |
| References | <ac8eddc9-1375-4387-9fe4-89a8a11ef11f@googlegroups.com> <1o6dnRRLlOIZI5TOnZ2dnUVZ7oednZ2d@bt.com> <79f3dad1-4e94-434c-83f1-6c0eeff87ec3@googlegroups.com> |
| Message-ID | <I9udneg4xs0YlpbOnZ2dnUVZ8lednZ2d@bt.com> (permalink) |
On 24/02/14 04:47, Lew wrote:
> lipska the kat wrote:
<snip>
>> public class AntiSmartArseClass {
>
> It is pointless to put 'Class' into a class name, as we already now that it's a class from
> the (you guessed it) 'class' keyword.
... and here we have the smartarse master, master of smartarses, arse
master smart and smarter than an arse with a smart part.
> More to the point, thinking in terms of classes is a less powerful mode than
> thinking in terms of types.
ROFLOL. What complete and utter tosh. Really, your capacity for talking
bollocks is alive and well I see. You have been a bit quiet recently,
did the meds stop working?
> Names should be semantic, and not reflective of
> implementation.
Waffle waffle waffle.
>> public static void main(String[] args) {
>> int increment = 11;
>
> This would be better as a constant.
Well firstly, you buffoon, although const *is* a reserved word in Java
it is not currently used, do you mean final? We have been down this road
soooooo many time before in here haven't we?
>
>> int iterations = 8;
>>
>> int outerindex = 1;
>> int innerindex= 0;
>
> Looks like you're reinventing the 'for' loop here.
Yawn
>
>> while(outerindex <= iterations){
>
> Yep.
You are an idiot. I was paraphrasing the 'code' (if you can call it
that) posted by another smartarse master.
>> System.out.printf("%d", outerindex * increment);
>> innerindex = (outerindex * increment) % 10;
>
> And the nested 'for' loop.
Idiot
>> while(innerindex > 1){
>
> Which proves that you are all macho and everything, sure, but
> the problem is that these variables have too wide a scope. Use
> of the 'for' loop brings you proper scoping for free.
What on earth are you waffling about now? "all macho and everything"
Have you ever seen a head doctor? I'd bet there are quite a few Ph D's
floating about in that confused and befuddled cranial mass you presume
to call a brain.
>
>> System.out.printf("%d", --innerindex);
>> }
>> outerindex++;
>
> You really should follow the Java Naming Conventions, which call for camel
> case on these variables.
>
>> System.out.println();
>> }
>> }
>> }
>
> You're welcome.
Well this *has* been ... a waste of time (as usual).
Instead of being a *complete and utter* smartarse, why not post a
reworked version ... I alluded to the fact that the code could do with a
bit of a refactor, or did you miss that? Too busy being a smartarse I
suppose.
Idiot
--
Lipska the Kat©: Troll hunter, sandbox destroyer,
treacherous feline and farscape dreamer of Aeryn Sun
GNU/Linux user #560883 - http://www.linuxcounter.net
Back to comp.lang.java.programmer | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
java code "jay'el antonio" <jlantonio10@gmail.com> - 2014-02-20 16:03 -0800
Re: java code Stuart <DerTopper@web.de> - 2014-02-21 14:29 +0100
Re: java code Joshua Cranmer 🐧 <Pidgeot18@verizon.invalid> - 2014-02-22 01:10 -0600
Re: java code Jan Burse <janburse@fastmail.fm> - 2014-02-22 12:36 +0100
Re: java code Stuart <DerTopper@web.de> - 2014-02-22 13:57 +0100
Re: java code Joshua Cranmer 🐧 <Pidgeot18@verizon.invalid> - 2014-02-22 12:05 -0600
Re: java code Stuart <DerTopper@web.de> - 2014-02-22 20:02 +0100
Re: java code Kevin McMurtrie <mcmurtrie@pixelmemory.us> - 2014-02-23 00:52 -0800
Re: java code Roedy Green <see_website@mindprod.com.invalid> - 2014-02-21 08:55 -0800
Re: java code lipska the kat <lipskathekat@example.com> - 2014-02-23 09:25 +0000
Re: java code Lew <lewbloch@gmail.com> - 2014-02-23 20:47 -0800
Re: java code lipska the kat <lipskathekat@example.com> - 2014-02-24 09:06 +0000
Re: java code Arne Vajhøj <arne@vajhoej.dk> - 2014-02-24 19:23 -0500
Re: java code lipska the kat <lipskathekat@example.com> - 2014-02-25 09:22 +0000
Re: java code Lew <lewbloch@gmail.com> - 2014-02-25 15:08 -0800
Re: java code lipska the kat <lipskathekat@example.com> - 2014-02-26 08:47 +0000
Re: java code leif.roar@invalid.com (Leif Roar Moldskred) - 2014-02-25 03:56 -0600
Re: java code Daniel Pitts <newsgroup.nospam@virtualinfinity.net> - 2014-02-25 14:54 -0800
Re: java code lipska the kat <lipskathekat@example.com> - 2014-02-26 09:07 +0000
Re: java code Simon Lewis <simonlewis2001@gmail.com> - 2014-02-26 12:40 +0100
Re: java code lipska the kat <lipskathekat@example.com> - 2014-02-26 14:54 +0000
Re: java code Simon Lewis <simonlewis2001@gmail.com> - 2014-02-26 16:10 +0100
Re: java code lipska the kat <lipskathekat@example.com> - 2014-02-26 15:45 +0000
Re: java code Robert Klemme <shortcutter@googlemail.com> - 2014-02-27 14:01 +0100
Re: java code Simon Lewis <simonlewis2001@gmail.com> - 2014-02-27 14:48 +0100
Re: java code leif.roar@invalid.com (Leif Roar Moldskred) - 2014-02-27 09:49 -0600
Re: java code Joerg Meier <joergmmeier@arcor.de> - 2014-02-27 19:24 +0100
Re: java code Daniel Pitts <newsgroup.nospam@virtualinfinity.net> - 2014-02-26 12:53 -0800
Re: java code Lew <lewbloch@gmail.com> - 2014-02-28 16:10 -0800
Re: java code lipska the kat <lipskathekat@example.com> - 2014-03-01 08:36 +0000
Re: java code "Qu0ll" <Qu0llSixFour@gmail.com> - 2014-03-01 20:51 +1100
Re: java code lipska the kat <lipskathekat@example.com> - 2014-03-01 10:31 +0000
Re: java code "Qu0ll" <Qu0llSixFour@gmail.com> - 2014-03-01 21:44 +1100
Re: java code lipska the kat <lipskathekat@example.com> - 2014-03-01 10:49 +0000
Re: java code "Qu0ll" <Qu0llSixFour@gmail.com> - 2014-03-01 21:58 +1100
Re: java code lipska the kat <lipskathekat@example.com> - 2014-03-01 12:00 +0000
Re: java code "Qu0ll" <Qu0llSixFour@gmail.com> - 2014-03-02 11:36 +1100
Re: java code Daniel Pitts <newsgroup.nospam@virtualinfinity.net> - 2014-02-26 12:59 -0800
Re: java code David Lamb <dalamb@cs.queensu.ca> - 2014-02-28 20:42 -0500
Re: java code lipska the kat <lipskathekat@example.com> - 2014-03-01 08:58 +0000
Re: java code "Qu0ll" <Qu0llSixFour@gmail.com> - 2014-03-01 21:00 +1100
Re: java code lipska the kat <lipskathekat@example.com> - 2014-03-01 10:45 +0000
Re: java code "Qu0ll" <Qu0llSixFour@gmail.com> - 2014-03-01 22:04 +1100
Re: java code lipska the kat <lipskathekat@example.com> - 2014-03-01 12:13 +0000
Re: java code "Qu0ll" <Qu0llSixFour@gmail.com> - 2014-03-02 11:05 +1100
Re: java code lipska the kat <lipskathekat@example.com> - 2014-03-02 08:57 +0000
Re: java code "Qu0ll" <Qu0llSixFour@gmail.com> - 2014-03-02 22:02 +1100
Re: java code lipska the kat <lipskathekat@example.com> - 2014-03-02 11:57 +0000
Re: java code leif.roar@invalid.com (Leif Roar Moldskred) - 2014-03-02 06:57 -0600
Re: java code David Lamb <dalamb@cs.queensu.ca> - 2014-03-02 15:21 -0500
Re: java code rossum <rossum48@coldmail.com> - 2014-02-26 22:06 +0000
Re: java code "Qu0ll" <Qu0llSixFour@gmail.com> - 2014-02-27 14:01 +1100
Re: java code v_borchert@despammed.com (Volker Borchert) - 2014-03-01 19:52 +0000
csiph-web