Path: csiph.com!usenet.pasdenom.info!weretis.net!feeder4.news.weretis.net!border2.nntp.ams2.giganews.com!backlog4.nntp.ams3.giganews.com!backlog4.nntp.ams.giganews.com!border2.nntp.ams.giganews.com!Xl.tags.giganews.com!border1.nntp.ams.giganews.com!nntp.giganews.com!local2.nntp.ams.giganews.com!nntp.bt.com!news.bt.com.POSTED!not-for-mail NNTP-Posting-Date: Mon, 24 Feb 2014 03:06:13 -0600 Date: Mon, 24 Feb 2014 09:06:11 +0000 From: lipska the kat Organization: Trollbusters 3 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130308 Thunderbird/17.0.4 MIME-Version: 1.0 Newsgroups: comp.lang.java.programmer Subject: Re: java code References: <1o6dnRRLlOIZI5TOnZ2dnUVZ7oednZ2d@bt.com> <79f3dad1-4e94-434c-83f1-6c0eeff87ec3@googlegroups.com> In-Reply-To: <79f3dad1-4e94-434c-83f1-6c0eeff87ec3@googlegroups.com> Content-Type: text/plain; charset=ISO-8859-1; format=flowed Content-Transfer-Encoding: 8bit Message-ID: Lines: 98 X-Usenet-Provider: http://www.giganews.com X-AuthenticatedUsername: NoAuthUser X-Trace: sv3-hMWA9Hb2XUgJiMvmH1VbKyTiqof80K3fvT0tcV++q3kdVumgDLYVsjSW/oXfmjudX83YBMCBu/mywH6!YPCE1jYUAQypVa+HzjE/h5/0uHUIlIHqz4tviyY/aKMUyBTkeir7kt7GcBuw3lebUQiq7X7BRbmR X-Complaints-To: abuse@btinternet.com X-DMCA-Complaints-To: abuse@btinternet.com X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your complaint properly X-Postfilter: 1.3.40 X-Original-Bytes: 4226 Xref: csiph.com comp.lang.java.programmer:27581 On 24/02/14 04:47, Lew wrote: > lipska the kat wrote: >> public class AntiSmartArseClass { > > It is pointless to put 'Class' into a class name, as we already now that it's a class from > the (you guessed it) 'class' keyword. ... and here we have the smartarse master, master of smartarses, arse master smart and smarter than an arse with a smart part. > More to the point, thinking in terms of classes is a less powerful mode than > thinking in terms of types. ROFLOL. What complete and utter tosh. Really, your capacity for talking bollocks is alive and well I see. You have been a bit quiet recently, did the meds stop working? > Names should be semantic, and not reflective of > implementation. Waffle waffle waffle. >> public static void main(String[] args) { >> int increment = 11; > > This would be better as a constant. Well firstly, you buffoon, although const *is* a reserved word in Java it is not currently used, do you mean final? We have been down this road soooooo many time before in here haven't we? > >> int iterations = 8; >> >> int outerindex = 1; >> int innerindex= 0; > > Looks like you're reinventing the 'for' loop here. Yawn > >> while(outerindex <= iterations){ > > Yep. You are an idiot. I was paraphrasing the 'code' (if you can call it that) posted by another smartarse master. >> System.out.printf("%d", outerindex * increment); >> innerindex = (outerindex * increment) % 10; > > And the nested 'for' loop. Idiot >> while(innerindex > 1){ > > Which proves that you are all macho and everything, sure, but > the problem is that these variables have too wide a scope. Use > of the 'for' loop brings you proper scoping for free. What on earth are you waffling about now? "all macho and everything" Have you ever seen a head doctor? I'd bet there are quite a few Ph D's floating about in that confused and befuddled cranial mass you presume to call a brain. > >> System.out.printf("%d", --innerindex); >> } >> outerindex++; > > You really should follow the Java Naming Conventions, which call for camel > case on these variables. > >> System.out.println(); >> } >> } >> } > > You're welcome. Well this *has* been ... a waste of time (as usual). Instead of being a *complete and utter* smartarse, why not post a reworked version ... I alluded to the fact that the code could do with a bit of a refactor, or did you miss that? Too busy being a smartarse I suppose. Idiot -- Lipska the KatŠ: Troll hunter, sandbox destroyer, treacherous feline and farscape dreamer of Aeryn Sun GNU/Linux user #560883 - http://www.linuxcounter.net