Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1743248
| From | Bart Van Assche <Bart.VanAssche@wdc.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 1/3] scsi: ufs: Change HCI marco to actual bit position |
| Date | 2017-10-02 22:50 +0200 |
| Message-ID | <uwfP7-ur-83@gated-at.bofh.it> (permalink) |
| References | <uvjBo-uO-21@gated-at.bofh.it> <uvjBo-uO-13@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Sat, 2017-09-30 at 11:52 +0530, Alim Akhtar wrote: > Currently UFS HCI uses UFS_BIT() macro to get various bit > position for the hardware registers status bits. Which makes > code longer instead of shorter. This macro does not improve > code readability as well. > Lets re-write these macro definition with the actual bit position. Can the three patches in this series be combined into a single patch? > -#define UFS_BIT(x) (1L << (x)) > [ ... ] > +#define UFS_BIT(x) (1L << (x)) If you want to keep the three patches separate, please make sure that this patch does not modify the UFS_BIT() definition. Please also fix the spelling of the title of this patch (marco -> macro). Thanks, Bart.
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 1/3] scsi: ufs: Change HCI marco to actual bit position Alim Akhtar <alim.akhtar@samsung.com> - 2017-09-30 08:40 +0200 [PATCH 3/3] scsi: ufs: Remove unused UFS_BIT() macro Alim Akhtar <alim.akhtar@samsung.com> - 2017-09-30 08:40 +0200 Re: [PATCH 1/3] scsi: ufs: Change HCI marco to actual bit position Bart Van Assche <Bart.VanAssche@wdc.com> - 2017-10-02 22:50 +0200
csiph-web